0

Following this question, I tried to use lua-ul in a document. I got an error that the package couldn't be found. After some research, I discovered that lua-ul depends on a newer version of LuaTeX than is packaged with my OS (Debian). So, having read this question I installed afresh the newest version. Now I have this:

$ sudo ls /usr/local/texlive
> 2020  texmf-local

and I have set various environment variables as I need to: (I think)

# TexLive settings 
export MANPATH=$MANPATH":/usr/local/texlive/2020/texmf-dist/doc/man"
export INFOPATH=$INFOPATH":/usr/local/texlive/2020/texmf-dist/doc/info"
export PATH=$PATH":/usr/local/texlive/2020/bin/x86_64-linux"

Everything is ostensibly in order.

If I run tlmgr instll lua-ul then I get:

(running on Debian, switching to user mode!)

tlmgr: Remote repository is newer than local (2018 < 2020)
Cross release updates are only supported with
  update-tlmgr-latest(.sh/.exe) --update
Please see https://tug.org/texlive/upgrade.html for details.

But there is only one repository (which surely is as up to date as possible?!):

$ tlmgr repository list
> (running on Debian, switching to user mode!)
List of repositories (with tags if set):
    http://mirror.ctan.org/systems/texlive/tlnet (main)

What do I have to do to install the package?

I have tried:

I discovered that tlmgr should be run as root on Debian (I can't remember why or where I found this). But as this thread points out, that on it's own won't work because using sudo standardly doesn't use the user's environment variable settings. So I tried sudo "PATH=$PATH" tlmgr install luate and got the same error (exactly the same, verbatim).

What am I doing wrong? What should I do? Should I just accept that something won't work? I just want to underline properly! Thanks!

5
  • your environment variables are defined in the wrong order. You are appending the new paths so they come later in the search order. So you are still using the old debian version. If you edit the texlive setting file following the pattern: export PATH="/usr/local/texlive/2020/bin/x86_64-linux:$PATH", it should work.
    – ArTourter
    Apr 17, 2020 at 19:26
  • Progress! Thanks @ArTourter, that helped. Now if I run tlmgr install lua-ul I get an error saying I don't have permission (which I should get running it without sudo, but didn't before, so something's working). But running it with sudo I still get the error message as above. Apr 17, 2020 at 20:18
  • 1
    you need to affect the path used by sudo not just your standard path Apr 17, 2020 at 20:22
  • You're right of course! How should I do that in a way which will make this work? I have just tried the following: sudo "PATH=$PATH" tlmgr install lua-ul, sudo -E tlmgr install lua-ul, sudo --preserve-env=PATH tlmgr install lua-u. All returned the same error message as above. Apr 17, 2020 at 20:31
  • if you have put the texlive settings in /etc/profile.d, then you can tell sudo to load all these script with the -i flag. sudo -i which tlmgr should return /usr/local/texlive/2020/bin/tlmgr
    – ArTourter
    Apr 17, 2020 at 20:33

0

You must log in to answer this question.

Browse other questions tagged .