6

I am using auctex and previewing equations in emacs does not work for me. It seems that the problem is related to ghostscript. I tried to reinstall ghostscript using brew, but got the following error.

brew reinstall ghostscript
==> Reinstalling ghostscript 
==> Downloading https://homebrew.bintray.com/bottles/ghostscript-9.52.mojave.bottle.tar.gz
Already downloaded: /Users/user/Library/Caches/Homebrew/downloads/91f3c9535bda739dd9663190e036d7661f4e27463b96ea05c9b5db5a98ca9abe--ghostscript-9.52.mojave.bottle.tar.gz
==> Pouring ghostscript-9.52.mojave.bottle.tar.gz
Error: The `brew link` step did not complete successfully
The formula built, but is not symlinked into /usr/local
Could not symlink bin/dvipdf
Target /usr/local/bin/dvipdf
already exists. You may want to remove it:
  rm '/usr/local/bin/dvipdf'

To force the link and overwrite all conflicting files:
  brew link --overwrite ghostscript

To list all files that would be deleted:
  brew link --overwrite --dry-run ghostscript

Possible conflicting files are:
/usr/local/bin/dvipdf
/usr/local/bin/eps2eps
/usr/local/bin/gsbj
/usr/local/bin/gsdj
/usr/local/bin/gsdj500
/usr/local/bin/gslj
/usr/local/bin/gslp
/usr/local/bin/gsnd
/usr/local/bin/lprsetup.sh
/usr/local/bin/pdf2dsc
/usr/local/bin/pdf2ps
/usr/local/bin/pf2afm
/usr/local/bin/pfbtopfa
/usr/local/bin/pphs
/usr/local/bin/printafm
/usr/local/bin/ps2ascii
/usr/local/bin/ps2epsi
/usr/local/bin/ps2pdf
/usr/local/bin/ps2pdf12
/usr/local/bin/ps2pdf13
/usr/local/bin/ps2pdf14
/usr/local/bin/ps2pdfwr
/usr/local/bin/ps2ps
/usr/local/bin/ps2ps2
/usr/local/bin/unix-lpr.sh
/usr/local/share/man/man1/dvipdf.1
/usr/local/share/man/man1/eps2eps.1 -> /usr/local/share/man/man1/ps2ps.1
/usr/local/share/man/man1/gs.1
/usr/local/share/man/man1/gsbj.1 -> /usr/local/share/man/man1/gslp.1
/usr/local/share/man/man1/gsdj.1 -> /usr/local/share/man/man1/gslp.1
/usr/local/share/man/man1/gsdj500.1 -> /usr/local/share/man/man1/gslp.1
/usr/local/share/man/man1/gslj.1 -> /usr/local/share/man/man1/gslp.1
/usr/local/share/man/man1/gslp.1
/usr/local/share/man/man1/gsnd.1
/usr/local/share/man/man1/pdf2dsc.1
/usr/local/share/man/man1/pdf2ps.1
/usr/local/share/man/man1/pf2afm.1
/usr/local/share/man/man1/pfbtopfa.1
/usr/local/share/man/man1/printafm.1
/usr/local/share/man/man1/ps2ascii.1
/usr/local/share/man/man1/ps2epsi.1
/usr/local/share/man/man1/ps2pdf.1
/usr/local/share/man/man1/ps2pdf12.1 -> /usr/local/share/man/man1/ps2pdf.1
/usr/local/share/man/man1/ps2pdf13.1 -> /usr/local/share/man/man1/ps2pdf.1
/usr/local/share/man/man1/ps2pdf14.1 -> /usr/local/share/man/man1/ps2pdf.1
/usr/local/share/man/man1/ps2pdfwr.1
/usr/local/share/man/man1/ps2ps.1
==> Summary
🍺  /usr/local/Cellar/ghostscript/9.52: 671 files, 87.4MB
==> `brew cleanup` has not been run in 30 days, running now...
Error: Permission denied @ apply2files - /usr/local/share/ghostscript/9.10/Resource/Font/logo10.pfb

I looked online and saw that there is probably a conflict with MacTex (see this GitHub issue). Indeed I have MacTex 2015 installed.

I am not sure how to proceed in solving the problem.

Should I uninstall MacTex and then reinstall it? (It seems it cannot be done thoroughly)

Should I force the homebrew links as it suggests? It seems like other stuff will be broken by it.

I am a simple TeX user, so I don't really understand all the dependencies. My goal it to be able to preview the equations when writing latex in emacs. (BTW, I am able to view the equations when I write in orgmode on emacs).

4
  • 2
    Uninstalling MacTeX won't help, as there's no way to do it except by manually deleting whatever it installed (which is a limitation of Apple's Installer packages). One option would be to install the latest MacTeX-provided Ghostscript, but what other stuff would be broken by having homebrew overwrite the links? MacTeX itself doesn't care if Ghostscript is installed or not. It's only provided as a convenience for users. Apr 20, 2020 at 2:11
  • @AdamMaxwell Thanks for your comment. I still do not understand what in your opinion is a solution. Do you think installing the latest ghostscript from MacTex will solve it? Do you think letting homebrew link what it wants will not damage other things? Apr 20, 2020 at 9:16
  • If you need a new Ghostscript, either option should work fine, unless you have installed some other software that depends on the MacTeX-installed Ghostscript. I have no idea what that would be. If you're concerned about breaking MacTeX, I was just pointing out that it does not depend on Ghostscript. Apr 20, 2020 at 14:29
  • Thanks @AdamMaxwell. I did install ghostscript 9.50 given in the maxtex site and now it works! Apr 20, 2020 at 14:57

1 Answer 1

3

I use brew doctor and get a list of all broken symlinks.
In this list you will find /usr/local/share/ghostscript/9.10/Resource/Font/logo10.pfb and some other like this.
Then use sudo rm '/usr/local/share/ghostscript/9.10/Resource/Font/logo10.pfb' to remove it.
Maybe there are more than one in the same directory so you can use sudo rm -r '/usr/local/share/ghostscript/9.10/Resource/Font'.
Maybe this helps.

1
  • 1
    Welcome to TeX.SE!
    – Zarko
    Nov 8, 2020 at 12:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .