0

Does anybody use the cbcoptic package for Coptic?

I am using MikTex 2.9 with Babel. I downloaded the files from https://www.ctan.org/tex-archive/language/coptic/cbcoptic

I compiled the testcop.tex file and it looks great. But the file itself has some imprintable characters which show up as \xB0 when opened in TeXnicCenter. There seem to be macros, but no explanation or list whatsoever, and I have no idea how to enter and compile a text I created. I have started a University Coptic course, please, somebody help that I can articulate myself! Angelika

2
  • Welcome to TeX.SE. Can, please, you see this link if is it an help for you? tex.stackexchange.com/questions/419957/…
    – Sebastiano
    Apr 22, 2020 at 10:31
  • In the package that you linked to, there is a README file - under "MAPPINGS AND LIGATURES" is a list of coptic characters and how to write them. Is this what you need to be able to edit? Apr 22, 2020 at 12:37

3 Answers 3

2

There is no need to install the package manually, it is both in miktex and texlive.

The style tries to make use of byte B0 (the degree symbol in latin1 encoding) as a command (looks like something to enable a hyphenation). This is not the greatest idea in the time of utf8. But it also define \0 as a replacement. If I exchange every ° (8bit encoded) by 0 in the test file it compiles.

But probably it would be better if you used an unicode engine like lualatex or xelatex and a suitable font:

\documentclass[]{article}

\usepackage{fontspec}
\setmainfont{FreeSerif}
\begin{document}
ⲀⲁⲂⲃⲄⲅⲆⲇⲈⲉ
\end{document}

enter image description here

3
  • Hi, all, sorry to get back so late to your answers, I was extremely busy with Egyptology. A late "Thank you very" much to all, especially Ulrike. One question remains though: How do I get what is between \begin{document} and \end{document} into my TechnicCenter editor? Looks like I am missing some fonts in Windows (Windows 7) \documentclass[]{article} \usepackage{fontspec} \setmainfont{FreeSerif} \begin{document} ⲀⲁⲂⲃⲄⲅⲆⲇⲈⲉ \end{document}
    – Fuzzy
    Jul 10, 2020 at 8:31
  • sorry I have no idea how good the support for unicode is in windows 7 (probably not so good, ...). I have windows 10 since quite some time. Jul 10, 2020 at 8:35
  • Thanks, Ulrike, I am fine with unicode when I use XeLatex. But that is not the question. In your example you have some coptic characters between \begin{document} and end{document}. The question is about my TexnicCenter editor, an Ascii editor: How do I get those coptic letters into my file so I can compile them. Do I use the Unicode numbers=
    – Fuzzy
    Jul 10, 2020 at 8:38
2

If switching to lualatexor xelatex is an option (and your system is up to date) you can set Coptic text with babel.

\documentclass{article}

\usepackage{babel}

\babelprovide[import, main]{coptic}

\babelfont{rm}[Renderer=Harfbuzz]{FreeSerif}
% A nice alternative:
% \babelfont{rm}[Renderer=Harfbuzz]{new_athena_unicode.ttf}

\begin{document}

ⲟⲩⲙⲁⲉⲓⲛ ⲡⲉ ⲛ̅ⲧⲉ ⲧⲉϥϭⲟⲙ.

ⲛⲓⲙ ⲧⲉ ⲧⲙⲁⲁⲩ ⲛ̅ ⲓⲱϩⲁⲛⲛⲏⲥ?

ⲙⲉϣⲁⲕ ⲛ̅ⲧⲟϥ ⲡⲉ ⲡⲉⲭ̅ⲥ̅.

\end{document}

coptic babel

I found these texts in the net, but I don't remember where.

See also What's new in babel 3.42.

0

The best option is to use the "Babel" package and compile with "Lualatex" and make your citations using "Biblatex". I have been using coptic language for a long time now in my documents. You can refer to the answer provided here. I asked the same question a very long time ago. Biblatex usage for multiple languages in same citation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.