7

Consecutive footnotes can be separated by commas by invocation of the multiple option of the footmisc package:

enter image description here

\documentclass{article}
\usepackage[multiple]{footmisc}
\begin{document}
Comma delineation of consecutive footnotes fails upon conversion to endnotes%
\footnote{First note.}%
\footnote{Second note.}.%
\end{document}

This comma delineation fails, however, if footnotes are converted to endnotes using the endnotes package:

enter image description here

\documentclass{article}
\usepackage{endnotes}
\let\footnote=\endnote
\usepackage[multiple]{footmisc}
\begin{document}
Comma delineation of consecutive footnotes fails upon conversion to endnotes%
\footnote{First note.}%
\footnote{Second note.}.%
\theendnotes
\end{document}

How can one preserve automated comma delineation of consecutive endnotes?

2

2 Answers 2

4

Manual solution

An admittedly not very comfortable solution is doing it manually, for example with KOMA-Script's \multiplefootnoteseparator:

\documentclass{scrartcl}
\usepackage{endnotes}
\let\footnote=\endnote

\begin{document}

Comma delineation of consecutive footnotes fails upon conversion to
endnotes\footnote{First note.}\multiplefootnoteseparator\footnote{Second
  note.}.

\theendnotes

\end{document}

enter image description here

Or with a standard class something like this:

\documentclass{article}
\newcommand*\multiplefootnoteseparator{%
  \textsuperscript{\multfootsep}\nobreak
}
\newcommand*\multfootsep{,}
\usepackage{endnotes}
\let\footnote=\endnote

\begin{document}

Comma delineation of consecutive footnotes fails upon conversion to
endnotes\footnote{First note.}\multiplefootnoteseparator\footnote{Second
  note.}.

\theendnotes

\end{document}

enter image description here

The package scrextend may also be loaded to integrate KOMA-Script's \multiplefootnoteseparator in standard classes.

Automatic Solution

My package fnpct offers a different solution. If loaded together with the endnotes “it just works”:

\documentclass{article}
\usepackage{endnotes}
\usepackage{fnpct}

\begin{document}

Comma delineation of consecutive footnotes fails upon conversion to
endnotes\endnote{First note.}\endnote{Second note.}.  \theendnotes

\end{document}

enter image description here

fnpct also reverses the fullstop and the footnote markers but that can be changed with a package option.

\documentclass{article}
\usepackage{endnotes}
\let\footnote\endnote
\usepackage{fnpct}
\setfnpct{reverse,before-punct-space=0pt}

\begin{document}

Comma delineation of consecutive footnotes fails upon conversion to
endnotes\footnote{First note.}\footnote{Second note.}.

\theendnotes

\end{document}

enter image description here

3
  • Just a note. I tested the fnpct examples above due to tex.stackexchange.com/questions/388809, and I get an error about \pdf@strcmp being undefined, with up-to-date TL17. Aug 29, 2017 at 20:04
  • Looked closer, it stems from the translations package (line 90). \usepackage{pdftexcmds} will fix it, but I don't know if that's the best path. Aug 31, 2017 at 14:54
  • 1
    @TorbjørnT. thanks. That's a missing dependency in translations. I'll send a fix to CTAN later today
    – cgnieder
    Aug 31, 2017 at 16:03
0

I had a similar problem and the footmisc package did not work. I did the following

\footnote{note1}\vphantom{d}$^{\text{,}}$\footnote{note2}

It's quick and dirty but it worked.

1
  • Instead of \vphantom{d}$^{\text{,}}$ I'd rather use \textsuperscript{,}
    – cgnieder
    Sep 10, 2014 at 16:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .