81

when I use

\begin{enumerate}[I]
\item 
...

I get

I
II

how I can get

i
ii

?

I try with

\renewcommand{\theenumi}{\roman{enumi}}
\renewcommand{\labelenumi}{\theenumi}

in the begin of file, but not fix the problem.

120

There are a number of ways. Here's using the enumerate package:

enter image description here

\documentclass{article}
\usepackage{enumerate}% http://ctan.org/pkg/enumerate
\begin{document}
\begin{enumerate}[I]
  \item One
  \item Two
  \item Three
\end{enumerate}

\begin{enumerate}[i]
  \item One
  \item Two
  \item Three
\end{enumerate}
\end{document}

Here's another method via the enumitem package. It yields the same output as above:

\documentclass{article}
\usepackage{enumitem}% http://ctan.org/pkg/enumitem
\begin{document}
\begin{enumerate}[label=\Roman*]
  \item One
  \item Two
  \item Three
\end{enumerate}

\begin{enumerate}[label=\roman*]
  \item One
  \item Two
  \item Three
\end{enumerate}
\end{document}

And then, without any packages:

\documentclass{article}
\renewcommand{\labelenumi}{\theenumi}
\begin{document}
\renewcommand{\theenumi}{\Roman{enumi}}%
\begin{enumerate}
  \item One
  \item Two
  \item Three
\end{enumerate}

\renewcommand{\theenumi}{\roman{enumi}}%
\begin{enumerate}
  \item One
  \item Two
  \item Three
\end{enumerate}
\end{document}
  • 1
    There's also the paralist package, that works just like enumerate in this case. – Christian May 2 '12 at 6:06
  • 2
    Unfortunately, with paralist the 8th item is misaligned (with enumerate it's correct). – Javier Bezos May 2 '12 at 7:04
21

If you want to type:

I.

II.

III.

Use:

\documentclass{article}
\begin{document}
\usepackage{enumerate}
\begin{enumerate}[I.]
  \item my text
  \item my text
  \item my text
\end{enumerate}

Another possibility for [I.] is [(I)], which gives:

(I)

(II)

(III)

  • 3
    The question is how to have lowercase roman numeral, not to add a period/dot after the Roman numeral. – Guido Apr 2 '13 at 11:29
  • 2
    but this was useful information, so thanks. – Tasos Papastylianou Jan 1 '17 at 14:46
  • Unfortunately this package adds the side-effect of changing the indentation for the items - is there any way to avoid this change? – Dmitri Zaitsev Jul 5 at 1:53
  • @DmitriZaitsev You might want to check out enumitem package (with package option shortlabels. It's more customizable than enumerate. – 6005 Nov 19 at 1:36
3

If you're using the beamer class, try something like:

\setbeamertemplate{enumerate item}{(\roman{enumi})}

or

\setbeamertemplate{enumerate subitem}{(\roman{enumii})}

See: Problem with enumerate package in beamer class

  • Just use [label=(\roman*)] – Smaillns May 31 at 11:58
  • @Smaillns, have you tested it? This would require an extension package. – PatrickT Jun 2 at 14:20
  • \usepackage{enumitem} – Smaillns Jun 5 at 10:32
  • Note: you can remove the braket "()", and add what you want, for instance \begin{enumerate}[label=\roman*] – Smaillns Jun 5 at 10:40
  • 1
    This is covered by Werner's answer, while my answer was focused on the beamer class specifically. – PatrickT Jun 5 at 16:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.