44

I'm using todonotes to make notes on my thesis. I'd like to be able to put some dot-points on a couple of the larger notes, like this:

\todo[inline]{
  \begin{itemize}
    \item blah blah blah
  \end{itemize}
}

But I get this error message:

! Argument of \reserved@a has an extra }.
<inserted text>
            \par
l.9 }

Is there anything I can do to get around this, or is it basically not worth trying?

2 Answers 2

57

You have to use the caption option:

\documentclass{article}
\usepackage{todonotes}
\begin{document}
\todo[inline,caption={}]{
  \begin{itemize}
    \item blah blah blah
  \end{itemize}
}
\end{document}

As described on page 12 of the manual LaTeX will otherwise try to embed a minipage which leads to an error.

2
  • 2
    Excellent, works perfectly. Ah, the arcana of TeX. Thanks.
    – naught101
    Commented May 3, 2012 at 1:12
  • To me it prints a colon, as part of the caption. Any possibility to remove that colon? Commented Feb 25, 2019 at 16:53
-1

The colon problem occurs if the prependcaption option is set in the package options.

If you remove this option, the set caption (or the colon, if the caption is empty) is no longer displayed on the left.

3
  • This seems unrelated to the question...
    – naught101
    Commented Aug 2, 2022 at 22:48
  • This answers Zoltán Csátis question on how to remove the colon in the empty caption I'm new to this forum and can't comment directly due to a lack of reputation.
    – Gotopos
    Commented Aug 4, 2022 at 9:40
  • Welcome! Please interact with the site elsewhere in order to get some rep. You only need one answer upvote or 2 question upvotes to get enough rep to comment :)
    – naught101
    Commented Aug 5, 2022 at 1:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .