1

Hope you're safe!

My bibliography still includes URLs and DOIs despite the fact that I've included DOI=false etc in the options for the Biblatex package. How can I remove them?

Here's a MWE:

\documentclass[12pt]{article}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@article{Rayo2002,
    author = {Rayo, Agust{\'{i}}n},
    doi = {10.1111/1468-0068.00379},
    file = {:Users/James/Documents/St Andrews/Philosophy/MPhil/MPhil Thesis/Readings/Nihilism, Monism, {\&} Pluralism/Word and Objects Rayo.pdf:pdf},
    issn = {0029-4624},
    journal = {No{\^{u}}s},
    month = {sep},
    number = {3},
    pages = {436--464},
    publisher = {Blackwell Publishing Ltd},
    title = {{Word and Objects}},
    url = {https://onlinelibrary.wiley.com/doi/abs/10.1111/1468-0068.00379},
    volume = {36},
    year = {2002}
}

@article{Cartwright1994,
    author = {Cartwright, Richard L.},
    file = {:Users/James/Library/Application Support/Mendeley Desktop/Downloaded/Cartwright - 1994 - Speaking of Everything.pdf:pdf},
    journal = {No{\^{u}}s},
    number = {1},
    pages = {1--20},
    title = {{Speaking of Everything}},
    url = {https://www.jstor.org/stable/2215917?seq=1{\&}cid=pdf-reference{\#}references{\_}tab{\_}contents},
    volume = {28},
    year = {1994}
}
\end{filecontents}

\usepackage[style=apa, doi=false, url=false, isbn=false, date=year, natbib=true]{biblatex}
\addbibresource{\jobname.bib}
\setlength\bibitemsep{1.5\itemsep}
\AtEveryBibitem{\clearfield{chapter}} %gets rid of chapters
\DeclareFieldFormat{apacase}{#1} %stops capitalisation
\AtEveryBibitem{\clearfield{number}} %clears issue numbers
\DeclareFieldFormat[article]{volume}{\apanum{#1}} %de-italicises volume numbers

\title{Test Document}

\begin{document}

\maketitle

Plural accounts of quantification, such as those endorsed by \citet{Cartwright1994} and \citet{Rayo2002}, allow one to quantify over absolutely everything without commiting oneself to the paradoxical universal set.

\printbibliography

\end{document}

Which outputs:

enter image description here

Thanks for your help!

9
  • What version of biblatex-apa are you using? It should (and does! - at least for me) work in current versions of both biblatex-apa (7th. edition) and biblatex-apa6 (6th. edition). See github.com/plk/biblatex-apa/pull/92. – moewe Apr 26 '20 at 14:58
  • Keep in mind, though, that biblatex-apa implements APA style as closely as possible. As such you can't expect a lot of configuration options that deliberately deviate from APA style. – moewe Apr 26 '20 at 15:04
  • 1
    Not that it matters for the question, but you (or your .bib file program/exporter) should not escape special character in the URL field. url = {https://www.jstor.org/stable/2215917?seq=1{\&}cid=pdf-reference{\#}references{\_}tab{\_}contents}, is wrong. It would be better to just have url = {https://www.jstor.org/stable/2215917?seq=1&cid=pdf-reference#references_tab_contents},. Though you may want to double check if you need all that, mayb eurl = {jstor.org/stable/2215917},` is enough. – moewe Apr 26 '20 at 15:09
  • ... There is also eprint = {2215917}, eprinttype = {jstor}, – moewe Apr 26 '20 at 15:10
  • 1
    I just realised there was a typo in one of my comments above. Of course I meant "maybe url = {https://www.jstor.org/stable/2215917}, is enough". – moewe Apr 26 '20 at 15:55
0

With version v9.6 (2020/02/22) of biblatex-apa or above (the current version is v9.10 from 2020-04-26) the options doi, eprint and url work again and can be used to remove the respective online info. With those versions the MWE works as expected and produces the desired output.

This came after a short period of time where those options were effectively disabled in version v9.0 to v9.5 of biblatex-apa. See https://github.com/plk/biblatex-apa/pull/92.

Update your system to make sure you have at least biblatex-apa v9.6.


Note that v9.0 and above of biblatex-apa implement APA style from the 7th edition of the Publication Manual of the American Psychological Association.

Versions v1.0 to v7.9 of biblatex-apa implemented APA style from the 6th edition of the manual.

If you want APA style (6th edition) you should use biblatex-apa6 (style=apa6). This is especially important for people updating from older systems, because style=apa, essentially changes APA versions from 6th-ed. APA style to 7th-ed. APA style in November 2019.


Not that it matters for the question, but you (or your .bib file program/exporter) should not escape special character in the URL field.

url = {https://www.jstor.org/stable/2215917?seq=1{\&}cid=pdf-reference{\#}references{\_}tab{\_}contents},

is wrong. It would be better to just have

url = {https://www.jstor.org/stable/2215917?seq=1&cid=pdf-reference#references_tab_contents},

Though you may want to double check if you need all that, maybe

url = {https://www.jstor.org/stable/2215917},

is enough. There is also

eprint     = {2215917},
eprinttype = {jstor}, 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.