0

Geometry does not seem to produce what I need and goes for the default values. The text is 18 by 14 cm in this case, but not anywhere near to 18 by 11 cm.

\documentclass[12pt,oneside]{memoir}
\usepackage[utf8]{inputenc}
\usepackage[pass,layoutwidth=11cm,layoutheight=18cm,bindingoffset=0]{geometry}
\usepackage{calc}
\usepackage{textcomp}
\usepackage{microtype}
\usepackage{nicefrac}
\usepackage{lipsum}

\tolerance=1
\emergencystretch=\maxdimen
\hyphenpenalty=10000
\hbadness=10000

\begin{document}

\lipsum

\end{document}
  • 1
    you are specifying the layout options not the size of the text block – David Carlisle Apr 29 at 18:37
  • 1
    possibly you want [text={11cm,18cm}] – David Carlisle Apr 29 at 18:44
  • This `\tolerance=1 \emergencystretch=\maxdimen \hyphenpenalty=10000 \hbadness=10000' allows to avoid word-breaking at line ends. Why? 1. Ancient Greek text, no word-wrap is possible, 2. some texts I have to deliver for further editing by other people in Word, I leave it to the people on the other end to turn on word-wrap and word-breaking if they so desire. – Dmitry Starostin Apr 29 at 20:11
  • All worked perfectly, thank you. – Dmitry Starostin Apr 29 at 20:25
  • It is self-contradictory, but it is a necessary tradeoff in two cases: 1. justified text in Ancient languages 2. Russian texts to be edited on the other side: Russian words are longer, so to avoid unwanted word-breaks [which in some cases I had to remove and adjust by hand] I have to use a very strict and rigid rule. It is one button in Word to torn word-breaking back on. – Dmitry Starostin Apr 29 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.