I'm having exactly the same issue as here, also using Biber 2.14, albeit I didn't upgrade, downgrade, change TexLive version, change encoding or (seemingly) do anything. It's like Biber suddenly quit parsing dates on me.

Whether the bibfile is encoded in ASCII or UTF-8 makes no difference. Whether the date is a short format or the full YYYY-MM-DD makes no difference. I'm not sure what else to test.

Here's a MWE and the associated .blg file:

        author       = {John Doe},
        title        = {A Title},
        date         = {2020-01-01},
        %date       = {2020}
        journaltitle = {Journal},


[1] Config.pm:304> INFO - This is Biber 2.14
[1] Config.pm:307> INFO - Logfile is 'mwe.blg'
[154] biber-darwin:322> INFO - === Thu Apr 30, 2020, 11:04:33
[185] Biber.pm:415> INFO - Reading 'mwe.bcf'
[354] Biber.pm:943> INFO - Found 1 citekeys in bib section 0
[384] Biber.pm:4256> INFO - Processing section 0
[385] Utils.pm:75> INFO - Globbing data source 'mwe.bib'
[385] Utils.pm:91> INFO - Globbed data source 'mwe.bib' to mwe.bib
[401] Biber.pm:4455> INFO - Looking for bibtex format file 'mwe.bib' for section 0
[402] bibtex.pm:1653> INFO - LaTeX decoding ...
[406] bibtex.pm:1471> INFO - Found BibTeX data source 'mwe.bib'
[437] Utils.pm:304> WARN - Entry 'JD2020' (mwe.bib): Invalid format '2020-01-01' of date field 'date' - ignoring
[457] UCollate.pm:68> INFO - Overriding locale 'en-US' defaults 'normalization = NFD' with 'normalization = prenormalized'
[457] UCollate.pm:68> INFO - Overriding locale 'en-US' defaults 'variable = shifted' with 'variable = non-ignorable'
[457] Biber.pm:4084> INFO - Sorting list 'nty/global//global/global' of type 'entry' with template 'nty' and locale 'en-US'
[457] Biber.pm:4090> INFO - No sort tailoring available for locale 'en-US'
[461] bbl.pm:652> INFO - Writing 'mwe.bbl' with encoding 'UTF-8'
[463] bbl.pm:755> INFO - Output to mwe.bbl
[463] Biber.pm:128> INFO - WARNINGS: 1

The \printbibliography output actually looks like this:
[1] John Doe. “A Title”. In: Journal ().

In my actual thesis, all the dates are gone from the pdf output.

  • 1
    Maybe your Biber cache is corrupted. Try deleting it. Follows the steps in tex.stackexchange.com/q/140814/35864. When you have deleted the cache, run biber --help from the command line. That will take a while (Biber needs to unpack itself), do not kill or otherwise stop the process, wait for it to finish.
    – moewe
    Apr 30, 2020 at 5:39
  • 1
    I have a hunch that the cache problem was the issue in the question you liked (tex.stackexchange.com/q/536068/35864) and it also was in issue in the recent github.com/plk/biber/issues/312
    – moewe
    Apr 30, 2020 at 5:40
  • 1
    It seems like once again your hunches were correct. I ran rm -rf `biber --cache`, started biber manually, then compiled my thesis, and everything was back to normal. I should have backed up the cache before removing it, maybe we'd have had a chance to figure out what went wrong. Maybe next time… Thanks!
    – fairytalq
    Apr 30, 2020 at 5:53
  • @fairytalq When you say you started biber manually, do you just mean you ran it by itself with a Quick Build? I'm having a similar problem. Thanks!
    – NLing
    Nov 21, 2020 at 22:47
  • @NLing sorry for the late answer. I ran in from Texstudio with the Bibliography option in the Tools contextual menu.
    – fairytalq
    Mar 29, 2021 at 6:10

2 Answers 2


Biber is written in Perl, but to make it usable for people without a Perl installation and to make sure that all dependencies have the right versions, it is distributed in 'compiled' binary form that bundles all Perl dependencies using PAR::Packer.

On the first Biber run, Biber will unpack all its dependencies into a temporary cache location. Subsequent runs will use the dependencies from the cache.

Sometimes the cache gets corrupted during unpacking or afterwards (maybe due to anti-virus software). In that case Biber may behave quite weirdly for no apparent reason, sometimes you get useful errors, sometimes not.

In the past there was a very common error about a missing recode.xml: Biblatex/biber fails with a strange error about missing recode_data.xml file.

In cases of weird Biber errors, delete the Biber cache as described in Biblatex/biber fails with a strange error about missing recode_data.xml file. (If Biber is still working well enough biber --cache should give you the cache location. Otherwise you have to find the location manually, that is described in the linked answer as well as the Biber documentation)

Then rerun Biber (for example with biber --help from the command line), it is important that this Biber run can finish cleanly without interruption. Do not kill the process even if it takes way longer than you expected. (Since Biber unpacks itself this run takes longer than a usual Biber run.)

Recent issues with the Biber cache are https://github.com/plk/biber/issues/312 and quite probably also Biber 2.14 broken ? - Biber warning: [557] Utils.pm:304> WARN - Entry ...' (....bib): Invalid format '2018' of date field 'date' - ignoring.

  • So far this problem seems to systematically only appear on Mac systems. I would be very interested to hear about other constellations.
    – moewe
    Aug 12 at 10:12

As moewe guessed in his comment, the issue was Biber's cache being corrupted, and deleting the cache fixed it.

  • 1
    Please don't add "thank you" as an answer. Instead, accept the answer that you found most helpful. - From Review Apr 30, 2020 at 7:01
  • I can't accept the answer when it came as a comment, can I? edit: nevermind, moewe added a proper answer. I'll accept his.
    – fairytalq
    Apr 30, 2020 at 15:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .