4

I have been looking for days how do to this but unfortunately haven't yet managed to do it. I have some references in my biblatex bibliography. I am citing, for example let's say "Smith2018", in different pages of my document. I am citing it as a whole, not like different page intervals of Smith2018. Each time I cite it, not only it is shown with a different [number] in footnotes in different pages (in bibliography in the end is shown with just one number), it also increments the counter number for successive citations (thus creating jumps in the bibliography numbers in the end).

So, I cite Smith2018 in page 4. In that page and in the footnotes is shown as [1].

Then I cite Andreson2019 in page 5. In that page and in the footnotes is shown as [2].

After that I cite Smith2018 again in page 6. In that page and in the footnotes is shown as [3]. I want this to be shown as [1].

When I cite Johnson2020 in page 7, in that page and in the footnotes is shown as [4]. I want it to be [3], the next number after Andreson2019's since the second citation of Smith2018 will have to be the same number as the its first citation.

In the end of my document, in the bibliography, the citations are shown as:

[1] Smith2018 description (cited in page 4 and 6)

[2] Andreson2019 description (cited in page 5)

[4] Johnson2020 description (cited in page 7)

I don't like the jump from [2] to [4]. I want Johnson2020 to be [3].

How do I solve this problem?


A way around (not satisfactory enough) this is as follows:

I cite Smith2018 in page 4 like: \autocite[\protect\label{Smith2018}][]{Smith2018}. In that page and in the footnotes is shown as [1].

Then I cite Andreson2019 in page 5 like: \autocite[\protect\label{Smith2018}][]{Smith2018}. In that page and in the footnotes is shown as [2].

After that I link Smith2018 again in page 6 but without a citation like: \textsuperscript{\hyperref[Smith2018]{\ref*{Smith2018}}}. In that page it is shown as [1] (which is what I want) but it is not shown in the footnotes and doesn't count as a real citation.

When I cite Johnson2020 in page 7 like: \autocite[\protect\label{Smith2018}][]{Smith2018} , in that page and in the footnotes is shown as [3] (which is what I want).

In the end of my document, in the bibliography, the citations are shown as:

[1] Smith2018 description (cited in page 4) - Here page 6 is missing because the ref link I created in that page isn't a real citation!!!

[2] Andreson2019 description (cited in page 5)

[3] Johnson2020 description (cited in page 7)

There is no jump in the numbers [2] to [3] this time but the second citation (in page 6) of [1] is missing.

If it was not possibile to solve the problem above, how do I at least make the way around more acceptable? Thank you.

Edit:

\usepackage[backend=biber,

   citestyle=verbose-ibid,

   sorting=none,

   bibstyle=numeric,

   autocite=footnote,

   backref,

   backrefstyle=none,

   doi=true,

   url=true,

   maxnames=99,

]{biblatex}



\DefineBibliographyStrings{english}{

   backrefpage = {Cited on page},

   backrefpages = {Cited on pages},

} \renewbibmacro{pageref}{\iflistundef{pageref}

      {\printtext[parens]{Not cited}}

      {\printtext[parens]{\ifnumgreater{\value{pageref}}{1}

         {\bibstring{backrefpages}}

         {\bibstring{backrefpage}}

         \printlist[pageref][-\value{listtotal}]{pageref}}}}



\addbibresource{Bibliography.bib}

\usepackage{hyperref}



\begin{document}

...
7
  • 1
    Welcome! A minimal example of code showing the issue is needed to debug.
    – egreg
    May 4 '20 at 23:03
  • It's just the regular functioning of latex/biblatex referencing/citation management. No additional code from me... But, I would like to make some changes adding code (like renew some command or declare a new one) in order to have results shown above. May 4 '20 at 23:08
  • 3
    Applying different numbers to the same citation is not the regular functioning of latex/biblatex, of course, so you really need to supply a short but complete sample of what gives the problem. May 4 '20 at 23:15
  • Hi and welcome! Numeric bib style goes with numeric cite style (manual 3.3.2). Is the intention to have a full reference on first cite, and then ibid afterwards, or a See n 3, supra variation?
    – Cicada
    May 5 '20 at 8:42
  • @Some_Lost_Developer I'm afraid that the behaviour you describe is not normal, so we really do need an example of a 'complete' (but short) document showing the issue
    – Joseph Wright
    May 5 '20 at 9:25
2

From the code shown in the question it appears that you are doing something like this

\documentclass[british]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[backend=biber,
   citestyle=verbose-ibid,
   sorting=none,
   bibstyle=numeric,
   autocite=footnote,
]{biblatex}

\usepackage{hyperref}

\addbibresource{biblatex-examples.bib}


\begin{document}
Lorem\autocite[380]{sigfridsson}
ipsum\autocite[14]{nussbaum}
dolor\autocite[381]{sigfridsson}
sit\autocite[36]{geer}
amet\autocite[123]{worman}
\printbibliography
\end{document}

Example output

You are combining a citation style of the verbose family with a numeric bibliography style. This will not result in particularly useful output.

In your setup the verbose style produces footnote citations (that's how one usually uses it), which simply means that each citation produces a normal footnote (like the one you would get with \footnote) with a citation. The first mention of a source produces a full ('verbose') citation that looks like the bibliography entry. Subsequent citations of the same work just produce a short "author-title" like reference. This style is common in certain areas of the humanities (certainly in Germany) its structure is not unlike the note citations of the Chicago Manual of Style.

While verbose styles work with footnotes, they do not use the numbers of the footnotes as a unique label to refer to a particular citation (verbose-note and verbose-inote produces footnotes that refer to a previous footnote, but the note number on its own does not identify an entry uniquely and is not used as a label on its own). It is crucial that all numbers that verbose citations produce are only footnote numbers.

The numeric style on the other hand, uses label numbers to refer to entries in the bibliography. In such a scheme each entry should have a unique number.

So to reiterate the numbers produced in the citations in the example code are footnote numbers that have nothing to do with the label numbers generated by the numeric bibliography. You can make this absolutely clear if you introduce additional normal footnotes.

\documentclass[british]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[backend=biber,
   citestyle=verbose-ibid,
   sorting=none,
   bibstyle=numeric,
   autocite=footnote,
]{biblatex}

\usepackage{hyperref}

\addbibresource{biblatex-examples.bib}

\begin{document}
\null\vfill % just for the example
Hi\footnote{Hello}
Lorem\autocite[380]{sigfridsson}
dolor\footnote{Dolor}
ipsum\autocite[14]{nussbaum}
dolor\autocite[381]{sigfridsson}
dolor\footnote{Dolor}
sit\autocite[36]{geer}
amet\autocite[123]{worman}
\printbibliography
\end{document}

The upshot is that you can not combine verbose citations and a numeric bibliography and expect the numbers to match.

If you want numeric citations as they are commonly used in STEM fields, just go with

\documentclass[british]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[backend=biber,
   style=numeric,
   sorting=none,
]{biblatex}

\usepackage{hyperref}

\addbibresource{biblatex-examples.bib}

\begin{document}
\null\vfill % just for the example
Hi\footnote{Hello}
Lorem \autocite[380]{sigfridsson}
dolor\footnote{Dolor}
ipsum \autocite[14]{nussbaum}
dolor \autocite[381]{sigfridsson}
dolor\footnote{Dolor}
sit \autocite[36]{geer}
amet \autocite[123]{worman}
\printbibliography
\end{document}

In case you like superscript citations (Wikipedia style), I suggest to add square brackets to avoid confusion with real footnotes (unless you don't use footnotes).

\documentclass[british]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[backend=biber,
   style=numeric,
   sorting=none,
   autocite=superscript,
]{biblatex}

\newrobustcmd{\mkbibbracketedsuperscript}[1]{%
  \unspace\allowhyphens\textsuperscript{%
    \begingroup
    \protected\long\def\mkbibsuperscript##1{%
      \blx@warning{Nested superscript}%
      ##1}%
    \mkbibbrackets{#1}%
    \endgroup}}

\DeclareCiteCommand{\supercite}[\mkbibbracketedsuperscript]
  {\iffieldundef{prenote}
     {}
     {\BibliographyWarning{Ignoring prenote argument}}%
   \iffieldundef{postnote}
     {}
     {\BibliographyWarning{Ignoring postnote argument}}}
  {\usebibmacro{citeindex}%
   \usebibmacro{cite}}
  {\supercitedelim}
  {}

\DeclareMultiCiteCommand{\supercites}[\mkbibbracketedsuperscript]
  {\supercite}{\supercitedelim}

\addbibresource{biblatex-examples.bib}

\begin{document}
\null\vfill % just for the example
Hi\footnote{Hello}
Lorem \autocite[380]{sigfridsson}
dolor\footnote{Dolor}
ipsum \autocite[14]{nussbaum}
dolor \autocite[381]{sigfridsson}
dolor\footnote{Dolor}
sit \autocite[36]{geer}
amet \autocite[123]{worman}
\printbibliography
\end{document}

Bracketed superscript citations.

2
  • Wow, yeah "you can not combine verbose citations and a numeric bibliography and expect the numbers in footnotes with those in bibliography to match." explained everything. Thank you also for the possible solution. For the moment I am using this solution . Maybe later will try your solution too. May 6 '20 at 20:34
  • citestyle=verbose-ibid in biblatex was causing the "issue". I had activated it for another feature and as a side effect the numbering was altered (found out now). Commenting it disabled ibid capabilities and thus restored numbering to what I wanted. So, basically the behaviour I was getting with it wasn't the "normal" one. Thank you all. I'm answering this so if anyone else in the future has a similar problem, knows what to disable. Jun 5 at 5:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.