0

my preamble referencing package:

\usepackage[superscript,biblabel]{cite}

The .bib file is saved in directory, all other references are being picked up correctly. Tried to add new reference, when I compile and run I get the 'citation undefined' error but when I hover over (working in TeXstudio) the citation label in my main .tex body it picks up the right .bib entry in my main bib file. I've attached pic showing.enter image description here

How come I only get this error for a single reference and none of the others? I double checked the .bib file and replaced it (firstly using the IOP generated .bib then the google scholar generated .bib) and it won't work for either. It has all the required entry fields for article. I have several other article .bibs in my references file that are working fine.

EDIT: solved, the .bbl file had an error in an earlier reference and so it wasn't reading as far down as this reference in the file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.