1

GotIn.fd is a decorative initial font created by Dieter Steffman. It can be found on CTAN here. While drafting, I've been experimenting with numerous decorative initial fonts found at this archive. A number of them work as expected. EG

% ...within the preamble...
\input{Typocaps.fd}

% ...later in the document...
{\Huge\usefont{U}{Typocaps}{xl}{n}Check out this cool font!}\\

produces this output:

Typocaps.fd working as intended

This is not the case with GotIn.fd. EG:

% ...within the preamble...
\input{GotIn.fd}

% ...later in the document...
{\Huge\usefont{U}{GotIn}{xl}{n}Check out this cool font!}\\

produces this output:

GotIn.fd not working as intended

I am not clear what is going on here. Numerous other fonts from the same archive work as intended. A number of them last updated well before GotIn.fd. Maybe a more experienced LaTeX user can speak to this.

P.S., I'm using overleaf.

3
  • 3
    Probably the font has only uppercase letters.
    – Thérèse
    May 8 '20 at 0:40
  • Confirmed that by examining the font in FontForge (fontforge.org/en-US).
    – Thérèse
    May 8 '20 at 0:44
  • Welcome to TeX.SE. We generally prefer to work with "minimal working examples", so that we can copy/paste and immediately see what you're talking about. In this case, I think that just means adding \documentclass{article} ... \begin{document} ... \end{document}.
    – Teepeemm
    May 8 '20 at 2:06
2

@Thérèse was correct in their comment. The font requires the inputted characters be uppercase. Adjusting the code to be such:

% ...within the preamble...
\input{GotIn.fd}

% ...later in the document...
{\Huge\usefont{U}{GotIn}{xl}{n}CHECK OUT THIS COOL FONT!}\\

outputs the desired result. Thank you!

2
  • 2
    Suggestion: Always put \tracinglostchars=2 in all your TeX files, especially when fiddling with fonts: otherwise the warning message about missing characters in fonts appears only in the log file. (A design flaw in TeX IMO: it should have been possible to make it a fatal error.) May 8 '20 at 2:39
  • Thanks for the tip! I'm certain this should be a default feature when using the [draft] option.
    – hunter
    May 8 '20 at 3:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.