How I can bring AUCTeX not to format percent sign within \url{}?

enter image description here

The document will be set fine, but if some of such URLs are in a document, the source code does not look so good.


AUCTeX comes with plenty of style files which add support for the corresponding LaTeX package. For example, AUCTeX style hyperref.el includes additions catered by hyperref.sty.

AUCTeX manual says:

5.3 Automatic Parsing of TeX Files

AUCTeX depends heavily on being able to extract information from the buffers by parsing them. Since parsing the buffer can be somewhat slow, the parsing is initially disabled. You are encouraged to enable them by adding the following lines to your .emacs file.

(setq TeX-parse-self t) ; Enable parse on load.

[...] Even when you have disabled the automatic parsing, you can force the generation of style information by pressing C-c C-n. This is often the best choice, as you will be able to decide when it is necessary to reparse the file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.