I'm writing a document with the minted package. I've already rendered dozens of code listings with it, so it works under normal conditions.

I now have a file with a unicode character in the file name: MaîtreD.cs. When I try to include it in my document, I get an error.


This produces output in the log like this when I run pdflatex:

[128] [129]
runsystem(pygmentize -l csharp -f latex -P commandprefix=PYG -F tokenmerge -o _
minted-main/88B16BC26B71923D706C452E5C9ACC80.pygtex ./.code/Restaurant/f3a1320/
Restaurant.RestApi/Ma\unhbox \voidb@x \bgroup \let \unhbox \voidb@x \setbox \@t
empboxa \hbox {\OT1\i \global \mathchardef \accent@spacefactor \spacefactor }\l
et \begingroup \endgroup \relax \let \ignorespaces \relax \accent 94 \OT1\i \eg
roup \spacefactor \accent@spacefactor treD.cs)...executed.

! Package minted Error: Missing Pygments output; \inputminted was
probably given a file that does not exist--otherwise, you may need 
the outputdir package option, or may be using an incompatible build tool,
or may be using frozencache with a missing file.

See the minted package documentation for explanation.
Type  H <return>  for immediate help.

l.76 ...nt/f3a1320/Restaurant.RestApi/MaîtreD.cs}

This could be caused by using -output-directory or -aux-directory 
without setting minted's outputdir, or by using a build tool that 
changes paths in ways minted cannot detect, 
or using frozencache with a missing file.

As the log indicates, it chokes on the î character, which makes it conclude that the file doesn't exist. It does, though.

Obviously, I can just rename the file to MaitreD.cs. If I do that, the code renders like normal. This is a workaround if there's no solution to this problem, but I'd prefer to keep the name as is.

Is there anything to do about this, or am I just out of luck?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.