0

I'm writing an article mainly in armenian language and use for it \usepackage{armtex}. But in the middle of text I want to change it to english, but it doesn't work and continues to write armenian letters. I've tried using babel but it gives me error like this

Package babel Error: Unknown option `armenian'. Either you misspelled it

(babel)                or the language definition file armenian.ldf was not found.

also I've tried the commands like \foreignlanguage{english} , \select@language{english} but they didn't work. I also use \usepackage[utf8]{inputenc} How can I do it? please help.

3
  • 1
    Please provide a MWE. Are you using only armtex or also babel? In the first case, doesn't \aroff work for you? Not that I use armtex, I just read the docs. May 16 '20 at 8:44
  • I use the following packages \usepackage{armtex} \usepackage[utf8]{inputenc} but when I want to write english it just writes english word with armenian letters, I want to change the language in the middle of the text. I'm afraid I can't use babel because I get errors with that
    – Ani
    May 16 '20 at 10:27
  • ooh now I understand. \aroff works ! thank you ... and how can I continue with the main language after that?
    – Ani
    May 16 '20 at 10:32
0

To use Armenian as your main language in Babel, add the command

\babelprovide[import, main]{armenian}

to your preamble. I believe you’re still supposed to load English through the package option, usepackage[english]{babel}.

Update

This got bumped back to the front page, so I’ll provide an example. This requires LuaLaTeX or XeLaTeX.

\documentclass[english]{article}
\tracinglostchars=2
\usepackage{babel}
\usepackage{fontspec}
\usepackage{microtype}

\babelprovide[import, main]{armenian}
\defaultfontfeatures{ Scale = MatchLowercase, Ligatures = TeX }

\babelfont{rm}[Scale=1.0]{Gentium}
%% The Arain AMU fonts are available from:
%% http://arian.tarumian.am/?page_id=34&lang=en
\babelfont[armenian]{rm}{Arian AMU Serif}
\babelfont[armenian]{sf}{Arian AMU}
\babelfont[armenian]{tt}{Arian AMU Mono}

\setlength{\emergencystretch}{3em} % Allow more interwordd space in ugly paragraphs

\begin{document}
\section*{ՄԱՐԴՈՒ ԻՐԱՎՈՒՆՔՆԵՐԻ ՀԱՄԸՆԴՀԱՆՈՒՐ ՀՌՉԱԿԱԳԻՐ}

Բոլոր մարդիկ ծնվում են հավասար ու անօտարելի իրավունքներով և հիմնական ազատություններով։

Միավորված ազգերը պարտավորություն է ստանձնել պահպանել, խրախուսել ու պաշտպանել յուրաքանչյուր անհատի մարդու իրավունքները։ Այս պարտավորությունը բխում է Միավորված ազգերի կանոնադրությունից, որը վերահաստատում է աշխարհի ժողովուրդների հավատը մարդու հիմնական իրավունքների, անձի արժանապատվության ու արժեքի նկատմամբ։

Մարդու իրավունքների համընդհանուր հռչակագրում Միավորված ազգերի կազմակերպությունը պարզ ու հասկանալի ձևով ներկայացրել է այն իրավունքները, որոնք հավասարապես պատկանում են յուրաքանչյուր մարդու։

\begin{otherlanguage}{english}
The above should be an excerpt from the UN Declaration of Human Rights.
\end{otherlanguage}
\end{document}

Arian AMU Serif sample

In LuaLaTeX, if you remove the [english] option and change the \babelprovide line to

\babelprovide[import, main, onchar=ids fonts]{armenian}
\babelprovide[import, onchar=ids fonts]{english}

you will be able to type in either language, and LuaTeX will detect the language you are using. It will change fonts and hyphenation patterns accordingly.

2
  • sorry but \babelprovide[import, main]{armenian} doesn't work...
    – Ani
    May 16 '20 at 9:15
  • @Ani You also would need to load an Armenian font, but the exact details would depend on which engine and packages you want to use.
    – Davislor
    Oct 13 '20 at 2:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.