3

I'm having the following error message:

pdflatex: Not writing to ../chap1_langFormels/chap1_langFormels.aux (openout_any = p).

! I can't write on file `../chap1_langFormels/chap1_langFormels.aux'.
\@include ...\immediate \openout \@partaux #1.aux 
                                                  \immediate \write \@partau...
l.45 ...de{../chap1_langFormels/chap1_langFormels}

Project tree:

Main file to run first is principal/techniquesCompilation.tex

./chap1_langFormels:
chap1_langFormels.tex  x.log

./chap2_langRegulier:
chap2_langRegulier.tex

./chap3_langAlgebriques:
chap3_langAlgebriques.tex

./chap4_langRecEnumerables:
chap4_langRecEnumerables.tex

./principal:
structure.tex              techniquesCompilation.bcf  techniquesCompilation.log  techniquesCompilation.run.xml  x.tex
techniquesCompilation.aux  techniquesCompilation.idx  techniquesCompilation.pdf  techniquesCompilation.tex

Latex version

This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017/Debian) (preloaded format=latex)
 restricted \write18 enabled.

%%%%%%%%%%%% Edited after Ulrike Fischer comment

  1. If I change include by input
  2. tried also to move chapters into principal folder as shows folder tree below:

    ls -R .: chap1_langFormels chap3_langAlgebriques structure.tex techniquesCompilation.bcf techniquesCompilation.log techniquesCompilation.tex chap2_langRegulier chap4_langRecEnumerables techniquesCompilation.aux techniquesCompilation.idx techniquesCompilation.pdf x.tex

    ./chap1_langFormels: chap1_langFormels.aux chap1_langFormels.tex x.log

    ./chap2_langRegulier: chap2_langRegulier.tex

    ./chap3_langAlgebriques: chap3_langAlgebriques.tex

    ./chap4_langRecEnumerables: chap4_langRecEnumerables.tex

Whatever the case, getting the following error message:

(../chap1_langFormels/chap1_langFormels.tex
Chapitre 1.

! LaTeX Error: File `' not found.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.3 \chapter{Préambule}
                         %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%...

?

If I keep using include rather than input I am still getting the same error message than above.

3
  • 6
    you are trying to write to a parent folder. This is not allowed with this security settings. Move the chapter folders into the principal folder, or don't use \include but only \input. May 17, 2020 at 22:31
  • I have updated question above. still getting errors.
    – cProg
    May 18, 2020 at 9:44
  • well the error message changed, but I have no idea why your code is now trying to input a file without name. Try to minimize your code. Don't compile everything in one go. May 18, 2020 at 9:55

0

You must log in to answer this question.

Browse other questions tagged .