When I turn on instant preview, equations with labels will compile to something messed up, e.g.

enter image description here

The Lyx code looks fine.

enter image description here

Is this the intended behavior of instant preview with equation label? If not, how do I resolve it? Thanks!

  • It's probably not 'intended' in the sense that people specifically wanted this overprinting behaviour, but it may be hard to get a better result if the equation is very long, the equation number on the left and the label helpfully shown there as well. In general I would say issues like this should be reported to the developers directly. Or is your question how to suppress the label info (the eqn:NTKparam bit in the first picture)? – moewe May 20 at 6:42
  • I played around with LyX for a bit, but was not able to reproduce this specific overprinting behaviour. You may want to add a step-by-step recipe to reproduce the output you are getting, so other people have a chance of playing around with it as well. – moewe May 20 at 6:49
  • perhaps one of these bug reports is related: lyx.org/trac/ticket/10573 and lyx.org/trac/ticket/6190 – scottkosty May 20 at 14:04
  • @scottkosty Yes those bug reports reflect the same issues. The latter report suggested passing in "reqno" as a document class option, which solves the issue for me. – SorcererofDM May 20 at 15:36
  • @SorcererofDM Great! Would you mind uploading a .lyx minimal example on the bug report? Also, could you leave comments on the tickets describing the relationship between the two? If they are duplicates, we should close one. If they're not, we should at least reference the other and explain the connection (currently they do not even mention the other). – scottkosty May 20 at 17:05

@scottkosty mentions 2 relevant bug reports 1 and 2, and the latter suggested passing in "reqno" as a document class option. This changes the equation labeling to the right side (instead of the left as shown) and avoids overlapping the equation label with the equation. Since I'm OK with right side equation label, this solves the issue for me.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.