1

I urgently need help with this issue: Whatever I do, my LaTeX-document sets the titlepage and the chapters on the left side. According to the scrbook-documentation, it should start on the right. When I specify this option explicitly, nothing changes. What am I getting wrong here? I am using the most recent TeX-version and I tried the same on Overleaf. Furthermore, this also happens with book, memoir, ...

MWE:

\documentclass[
ngerman,
pdftex,
a4paper,     
12pt,       
twoside,     
openright,  
]{scrbook}

\usepackage{blindtext}



% Dokumentenanfang
\begin{document}



\begin{titlepage}
    \Huge My fancy title
\end{titlepage}



\chapter{This is an awesome chapter}

\blindtext

\section{Some section}

\blindtext



\end{document}

The results can be seen here: Nothing is set on the right side.

enter image description here enter image description here

  • \usepackage[right=8cm]{geometry} – Johannes_B May 25 at 12:05
  • The title page (page 1) is on the right side. The next one (page 2) is on the left side, etc. – hair-splitter May 25 at 12:16
  • I am wondering whether I was wrongly told that there is an issue. It seems like the margin on the odd pages, where chapters start, is correctly set. Right? However, if they persist on another solution, I may use the idea with gemometry? – junkmaster May 25 at 12:27
  • For example in Sumatra PDF reader there is a special view called book view. I guess there might be similar views in other readers. Try to set up your reader with that option and control again if your pdf is really not set up correctly (I bet it is). – Nico May 25 at 12:30
  • Okay, I guess the margin should be wider when the right side when the page should appear on the right. In case the requirement contradicts this, I can use gemoetry. Many Thanks to all! – junkmaster May 25 at 12:47
2

I think there is a missunderstanding ...

To visualize the typing area and the margins you can use package showframe. In the following MWE I corrected some class options to get rid of the corresponding warnings in the log file ...

With the following MWE

\documentclass[%
  ngerman,
% pdftex,        % <==================================================== not needed
  paper=a4,      % a4paper, <===========================================
  fontsize=12pt, % 12pt, <==============================================
% twoside,       % <===================================== standard with class scrbook
% openright,     % <===================================== standard with twoside option
]{scrbook}

\usepackage{blindtext}
\usepackage{showframe} % <==============================================


% Dokumentenanfang
\begin{document}

\begin{titlepage}
    \Huge My fancy title
\end{titlepage}

\chapter{This is an awesome chapter}
\blindtext

\section{Some section}
\blindtext

\end{document}

you get the following resulting pages:

Page 1, right page: first page

Page 2, left page, empty: page two

Page 3, right page: page three

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.