0

I am having problems with file permissions in Windows 10. I am using TeX Live 2020. PdfLaTeX/LuaLaTeX is unable to access files in my local texmf tree. I am getting the following error:

Process started: lualatex.exe -synctex=1 -interaction=nonstopmode "block1".tex

c:/texlive/texmf-local/tex/latex/ownsty/answers.sty: Permission denied

Process exited with error(s)

I can compile files that do not need access to my local texmf tree. I have checked my permissions. It seems OK to me.

enter image description here

enter image description here

0

This was a problem with the 2020 installer, which has since been solved. The permission problems are with the files, not with the directories. Instructions for fixing texmf-local can be found at http://www.tug.org/texlive/windows.html

I repeat them here:

  • In File Explorer, right-click the texmf-local folder
  • Choose Properties
  • Select the Security tab
  • Click the Advanced button
  • Click the Change permissions button and deal with the resulting UAC prompt
  • There is no need to change anything in the box with Permission entries. Instead: Check the checkbox 'Replace all child object permission entries with inheritable permission entries from this object'
  • Finally, click the OK button and click Yes in the resulting Windows Security dialog.
  • -

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.