0

I am getting an error claiming latex can't find the package acmart and it is not available in tlmgr.

3
  • Welcome to TeX.SE! But this isn't even close to enough information for anyone to help you. What system are you running? What version? What have you tried? What is the exact text of the error? And so forth. Commented May 27, 2020 at 18:35
  • Sorry, I actually did solve the problem, I just wanted to post it and the answer here for posterity. The answer does not depend on the specifics of my system, should I append my system information anyway?
    – fakedrake
    Commented May 27, 2020 at 20:11
  • 1
    No, no need, as it looks like there's an easy solution to the problem. But in general, more information is better. Commented May 28, 2020 at 1:17

1 Answer 1

3

acmart is not part of the distribution of basictex so it needs to be installed. Furthermore tlgmr (texlive's package manager) needs to be configured to know where to look for packages. Finally, it looks like tlmgr does not track down dependencies so they each need to be installed by hand. All this put together is resolved by the following sequence of commands:

sudo tlmgr option repository ctan
sudo tlmgr option repository http://mirror.ctan.org/systems/texlive/tlnet
sudo tlmgr update --all
sudo tlmgr install acmart
sudo tlmgr install iftex
sudo tlmgr install xstring
sudo tlmgr install environ
sudo tlmgr install totpages
sudo tlmgr install trimspaces
sudo tlmgr install manyfoot
sudo tlmgr install ncctools
sudo tlmgr install comment
sudo tlmgr install balance
sudo tlmgr install preprint
1
  • Thanks, but I don't think this actually provides an answer to the question ("Where is acmart?"; or, "Why can't tlmgr find acmart?). Commented May 27, 2020 at 18:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .