5

So every time I run code on TeXStudio, I would get

User/administrator updates are out-of-sync.

I have updated MikTeX as both admin and user on my machine, but I still get this message. How to fix this?

Note: I also realized that on TeXStudio, whenever I would run the file, I would get:

Process started: lualatex.exe -synctex=1 -interaction=nonstopmode "ThisFile".tex

lualatex: major issue: User/administrator updates are out-of-sync.

Process exited normally

Supposedly, the pdf file appears after this, but the first two lines appear again and I have to wait for the same amount of run time again before Process exited normally appears. I wonder if it's due to out-of-sync warning?

7
  • 1
    How did you update as user and as admin? Did you switch the modes in the MiKTeX console? – Ulrike Fischer May 30 '20 at 7:27
  • 1
    Yes I did. I updated from both modes but it didn’t work. – Superman May 30 '20 at 16:28
  • 1
    Please keep in mind that out-of-sync can mean: 1) user updates are behind admin updates 2) user updates are ahead admin updates. If 1), you have to update in user mode first. If 2), you have to update in admin mode first. – Christian Schenk May 31 '20 at 7:37
  • 1
    How would one know which one is which? – Superman May 31 '20 at 16:31
  • 1
    So if that’s the case, if I want to fix the problem, should I update the user first, then the admin? – Superman May 31 '20 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.