1

According to the APA 6th guide (e.g. https://research.moreheadstate.edu/c.php?g=107001&p=695202) if I have more than 6 authors, I should use "et al." from the first citation. I used this answer to get biblatex to print "et al." for all other quotes after I citied it once (How to get et al. beginning with the 2nd citation with biblatex-chicago). But now a citation with more than 6 authors is printed with all authors and not just the first author and "et al." Any idea how to achieve both at the same time? Below is my code:

\usepackage[style=apa,
backend=biber,
language=american,
hyperref=true,
uniquelist=true,
citetracker=true,
maxcitenames=1]{biblatex}
\DeclareLanguageMapping{american}{american-apa}

\AtEveryCitekey{\ifciteseen{}{\defcounter{maxnames}{99}}}

%bibfile        
\begin{filecontents}{myfile.bib}
@article{Hein.2020,
    author = {Hein, Andreas and Schreieck, Maximilian and Riasanow, Tobias and Setzke, David Soto and Wiesche, Manuel and B{\"o}hm, Markus and Krcmar, Helmut}
}
@article{Jacobides.2018,
    author = {Jacobides, Michael G. and Cennamo, Carmelo and Gawer, Annabelle}
}
\end{filecontents}

\begin{document}

\parencite{Jacobides.2018}
\parencite{Jacobides.2018}
\parencite{Hein.2020}. 

\end{document}

Which yields:

(Jacobides, Cennamo, and Gawer, 2018)

(Jacobides et. al, 2018)

(Hein, Schreieck, Riasanow, Setzke, Wiesche, Bohm, & Krcmar, 2020).

And should look like:

(Jacobides, Cennamo, and Gawer, 2018)

(Jacobides et. al, 2018)

(Hein et al., 2020)

0

Nevermind, I found the solution. I just needed to replace the maxnames 99 to 6:

\AtEveryCitekey{\ifciteseen{}{\defcounter{maxnames}{6}}}
0

On an up-to-date system, your MWE (with biblatex-apa6's style=apa6, instead of biblatex-apa's style=apa,, which produces 7th-edition APA style now), produces

\documentclass[american]{apa6}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}
\usepackage[style=apa6,
  backend=biber,
]{biblatex}

\begin{filecontents}{\jobname.bib}
@article{Hein.2020,
  author = {Hein, Andreas and Schreieck, Maximilian
            and Riasanow, Tobias and Setzke, David Soto
            and Wiesche, Manuel and B{\"o}hm, Markus and Krcmar, Helmut},
}
@article{Jacobides.2018,
  author = {Jacobides, Michael G. and Cennamo, Carmelo
            and Gawer, Annabelle},
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
\parencite{Jacobides.2018}

\parencite{Jacobides.2018}

\parencite{Hein.2020}
\end{document}

(Jacobides, Cennamo, & Gawer, n.d.)//(Jacobides et al., n.d.)//(Hein et al., n.d.)

which conforms exactly with APA6 requirements.

Note that I removed the options uniquelist=true, and maxcitenames=1: These are things that you should let the style take care of if you want full APA compliance. And there is no need to set any of these things directly in order to make biblatex-apa/biblatex-apa6 conform to APA style.


It is possible that you see a slightly different behaviour in your actual document in case you cite a different work by a similar set of authors. Then the uniquelist setting kicks in and expands the list to make sure that citation labels do not get collapsed into ambiguous/non-unique short forms.

Example

\documentclass[american]{apa6}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}
\usepackage[style=apa6,
  backend=biber,
]{biblatex}

\begin{filecontents}{\jobname.bib}
@article{Hein.2020,
  author = {Hein, Andreas and Schreieck, Maximilian
            and Riasanow, Tobias and Setzke, David Soto
            and Wiesche, Manuel and B{\"o}hm, Markus and Krcmar, Helmut},
}
@article{Hein.1990,
  author = {Hein, Andreas and Schreieck, Maximilian
            and Riasanow, Tobias and Setzke, David Soto
            and Wiesche, Manuel and B{\"o}hm, Markus and Emma Sigfridsson},
}
@article{Jacobides.2018,
  author = {Jacobides, Michael G. and Cennamo, Carmelo
            and Gawer, Annabelle},
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
\parencite{Jacobides.2018}

\parencite{Jacobides.2018}

\parencite{Hein.2020,Hein.1990}

\parencite{Hein.2020,Hein.1990}
\end{document}

(Hein, Schreieck, Riasanow, Setzke, Wiesche, Böhm, & Krcmar, n.d.; Hein, Schreieck, Riasanow, Setzke, Wiesche, Böhm, & Sigfridsson, n.d.)

This could be turned off by setting uniquelist=false, in the biblatex loading options, but it is my understanding that the default behaviour with uniquelist=minyear, is what APA style wants.


Note that this answer should still be applicable if you are using an older version of biblatex-apa, where 6th-edition APA style is produced by style=apa, and not style=apa6,.


In any case I suggest you do not change the value of maxnames manually in the document.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.