2

I am currently running the following code:

    \pdfminorversion=4
\documentclass[]{article}


\usepackage{tikz-cd}
\usepackage{adjustbox}



\begin{document}




$$\adjustbox{scale=1,center}{%
\begin{tikzcd}
\large 0               & \large 0               & \large 0               & \large 0                                 & \large 0                                  & \large 0                                  & \large 0                                  & \large 0                                  & \large 0 & \large 0 & \large 0 \\
\large 0               & \large 0               & \large 0               & \large 0                                 & \large 0                                  & \large 0                                  & \large 0                                  & \large 0                                  & \large 0 & \large 0 & \large 0 \\
\large 0               & \large 0               & \large 0               & {\large^\text{I}E^3_{4,1}} \arrow[rrruu] & {\large ^\text{I}E^3_{3,1}} \arrow[rrruu] & {\large ^\text{I}E^3_{2,1}} \arrow[rrruu] & {\large ^\text{I}E^3_{1,1}} \arrow[rrruu] & \large 0                                  & \large 0 & \large 0 & \large 0 \\
\large 0               & \large 0               & \large 0               & \large 0                                 & {\large ^\text{I}E^3_{3,0}} \arrow[rrruu] & {\large ^\text{I}E^3_{2,0}} \arrow[rrruu] & {\large ^\text{I}E^3_{1,0}} \arrow[rrruu] & {\large ^\text{I}E^3_{0,0}} \arrow[rrruu] & \large 0 & \large 0 & \large 0 \\
\large 0 \arrow[rrruu] & \large 0 \arrow[rrruu] & \large 0 \arrow[rrruu] & \large 0 \arrow[rrruu]                   & \large 0                                  & \large 0                                  & \large 0                                  & \large 0                                  & \large 0 & \large 0 & \large 0 \\
\large 0               & \large 0 \arrow[rrruu] & \large 0 \arrow[rrruu] & \large 0 \arrow[rrruu]                   & \large 0 \arrow[rrruu]                    & \large 0                                  & \large 0                                  & \large 0                                  & \large 0 & \large 0 & \large 0
\end{tikzcd}
}$$ 

\end{document}

It gives me following picture:

enter image description here

So you can see that initials and targets of arrow are correct, but two arrows sharing a single point as target and initial are not lie in same straight-line, i.e. to say picture is a kind of horrible. Can anyone help me? Thanks in advance.

4

You have a lot of things going on. First of all, you have 300 (more or less :-) ) warnings that \large do nothing in math mode, so get rid of it.

Then, there is a missing \usepackage{} for the \text command, which gives an error (why do you use it? it's just a number...)

Moreover, in LaTeX you should never use $$ for equations.

The main problem is because your cells in the diagram have different sizes, and so the "anchors" where the arrows point move around. One solution is to fix the sizes of the cells with \tikzcdset{cells={text width=2.2em, text height=1em, text depth=0.4em}} (you have to play with the numbers).

Finally, I have this:

\documentclass[]{article}

\usepackage{tikz-cd}
\usepackage{adjustbox}
\usepackage{amsmath}

\begin{document}

\[
\tikzcdset{cramped, cells={text width=2.2em, text height=1em, text depth=0.4em}}
\adjustbox{width=\textwidth, center}{
\begin{tikzcd}
 0               &  0               &  0               &  0                                 &  0                                  &  0                                  &  0                                  &  0                                  &  0 &  0 &  0 \\
 0               &  0               &  0               &  0                                 &  0                                  &  0                                  &  0                                  &  0                                  &  0 &  0 &  0 \\
 0               &  0               &  0               & {^\text{I}E^3_{4,1}} \arrow[rrruu] & { ^\text{I}E^3_{3,1}} \arrow[rrruu] & { ^\text{I}E^3_{2,1}} \arrow[rrruu] & { ^\text{I}E^3_{1,1}} \arrow[rrruu] &  0                                  &  0 &  0 &  0 \\
 0               &  0               &  0               &  0                                 & { ^\text{I}E^3_{3,0}} \arrow[rrruu] & { ^\text{I}E^3_{2,0}} \arrow[rrruu] & { ^\text{I}E^3_{1,0}} \arrow[rrruu] & { ^\text{I}E^3_{0,0}} \arrow[rrruu] &  0 &  0 &  0 \\
 0 \arrow[rrruu] &  0 \arrow[rrruu] &  0 \arrow[rrruu] &  0 \arrow[rrruu]                   &  0                                  &  0                                  &  0                                  &  0                                  &  0 &  0 &  0 \\
 0               &  0 \arrow[rrruu] &  0 \arrow[rrruu] &  0 \arrow[rrruu]                   &  0 \arrow[rrruu]                    &  0                                  &  0                                  &  0                                  &  0 &  0 &  0
\end{tikzcd}
}
\]

\end{document}

which compiles without errors to:

enter image description here

1
  • 1
    Thanks, it works.
    – User
    Jun 2 '20 at 9:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.