1

I asked about german quotes and biblatex here German quote shorthands from babel for biblatex but this problem seems different since german quotes are working partly. They work in the main text, they work partly in the bibtex text, but they fail at the beginning of a field with "`. Rather than lower German quotes, I get upper quotes plus lower german quotes.

enter image description here

\documentclass{article}


%\usepackage{german}
\usepackage[ngerman,main=english]{babel}
\useshorthands*{"}
\addto\extrasenglish{\languageshorthands{ngerman}}

\begin{filecontents}{ref.bib}


@incollection{Fanselow92,
        Address = {Berlin, New York},
        Author = {Gisbert Fanselow},
        Booktitle = {{Deutsche Syntax -- Ansichten und Aussichten}},
        Editor = {Ludger Hoffmann},
        Pages = {276--303},
        Publisher = {de Gruyter},
        Series = {Institut für deutsche Sprache, Jahrbuch 1991},
        Title = {{"`Ergative"' Verben und die Struktur des deutschen Mittelfelds}},
        Year = {1992}}


@article{Wegener85a,
        Author = {Heide Wegener},
        Journal = {Linguistische Berichte},
        Pages = {127--139},
        Title = {"`Er bekommt widersprochen"' -- Argumente Test/""Test für die Existenz eines Dativpassivs im Deutschen},
        Volume = {96},
        langid = {ngerman},
        Year = {1985}}

\end{filecontents}

\usepackage{bibentry}

\usepackage[
%autolang=other,
        backend=biber,
]{biblatex}
\addbibresource{ref.bib}

\begin{document}
Here's a citation
\bibentry{Fanselow92}

Test"=Sequenz "`Ergative"' Verben

\nocite{*}
\printbibliography
\end{document}

Edit I did not realize that the style added the quotation marks around the title. I rephrased my question with a different MWE here: Mysterious capitalization of German quotes shorthands useing biblatex

enter image description here

3
  • 2
    This has more to do with the bibliography style itself. The standard citation format sets the title under quotes. Hence, you get "Title" and if there are separate quotes in the title (as it is in your case), they will be printed like this. The question is, what do you actually want? You could e.g. try another citation style (like apa) where the title is not under quotes as is.
    – Steradiant
    Jun 5, 2020 at 9:41
  • Completely agree with Steradiant's analysis. It would be helpful to know what output you expect (not only for these cases, but also for @article/@incollection titles that don't come with their own quotation marks in the .bib file). The biblatex standard styles typeset titles that are not italic (italic titles are usually titles of stand-alone works) in quotation marks, so here you get double the quotation mark load. ...
    – moewe
    Jun 5, 2020 at 12:18
  • ... I wouldn't introduce an inconsistency by treating titles already containing quotation marks differently from titles that don't. But you can easily remove all quotation marks if you don't like them tex.stackexchange.com/q/462133/35864.
    – moewe
    Jun 5, 2020 at 12:19

1 Answer 1

3

I would suggest to load the (recommended) package csquotes and to use \enquote in the bib-file. The quotes will then be properly nested and adapted to the main language of your document. And if you use the autolang=language option they will even react to the langid field (see the second entry):

\documentclass{article}

\usepackage[ngerman,main=english]{babel}
\useshorthands*{"}
\addto\extrasenglish{\languageshorthands{ngerman}}

\begin{filecontents}{ref.bib}


@incollection{Fanselow92,
        Address = {Berlin, New York},
        Author = {Gisbert Fanselow},
        Booktitle = {{Deutsche Syntax -- Ansichten und Aussichten}},
        Editor = {Ludger Hoffmann},
        Pages = {276--303},
        Publisher = {de Gruyter},
        Series = {Institut für deutsche Sprache, Jahrbuch 1991},
        Title = {{\enquote{Ergative} Verben und die Struktur des deutschen Mittelfelds}},
        Year = {1992}}


@article{Wegener85a,
        Author = {Heide Wegener},
        Journal = {Linguistische Berichte},
        Pages = {127--139},
        Title = {\enquote{Er bekommt widersprochen} -- Argumente Test/""Test für die Existenz eines Dativpassivs im Deutschen},
        Volume = {96},
        langid = {ngerman},
        Year = {1985}}

\end{filecontents}

\usepackage{bibentry}
\usepackage{csquotes}
\usepackage[
autolang=langname,
        backend=biber,
]{biblatex}

\addbibresource{ref.bib}

\begin{document}

\nocite{*}
\printbibliography
\end{document}

enter image description here

8
  • The documentation claims autolang=langname, is only valid with polyglossia. If polyglossia is not used, the option is silently remapped to autolang=other,.
    – moewe
    Jun 5, 2020 at 12:09
  • 1
    Anyway, what I actually wanted to point out is that autolang=langaname, (autolang=other,) also changes the language of the bibliography entry ('pp. 127-139' becomes 'S. 127-139', 'and' becomes 'und' etc.). This may or may not be desired.
    – moewe
    Jun 5, 2020 at 12:11
  • @moewe yes right (I didn't want to imply that autolang is sensible, only that it has an effect). Jun 5, 2020 at 12:28
  • OK, I debugged this further and I realized that autolang=langname is what gives me the quotes back in the langsci environment. The quotes just do not work properly in the bibtex entries without this. I guess I messed up this question. I am sorry. I will start a new one. Jun 5, 2020 at 12:37
  • 1
    Don't do that. It is rather unfriendly to change a question and make an answer invalid. If you have a new question ask a new question. Jun 5, 2020 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.