I am following this guide to create an engine-file for TexShop to facilitate the use of the nomenclature package. However, after invoking the engine, it does not happen anything at all - I get no error messages, nor is a file created.

I am using TexShop 3.06 under MacOS Lion and already tried to rule out obvious mistakes (like forgotten return keys etc.). Even if I place echo-commands in the engine file, I get no output.

Are there any ideas on how to obtain a working menu entry?

  • Did you place the .engine file at ~/Library/TeXShop/Engines, and restart TeXShop? Also would be helpful to see the contents of this engine file? – Peter Grill May 7 '12 at 15:23
  • Did you make the engine file executable? In a Terminal window, chmod +x ~/Library/TeXshop/Englines/myengine.engine (where myengine.engine is whatever you named your engine file.) – Alan Munn May 7 '12 at 16:50
  • @PeterGrill: Sorry for the late reply... I placed the file in the mentioned folder, made it executable, and restarted TexShop. The content of the engine-file is basically the same as in the post mentioned above: #!/bin/bash set path= ($path /usr/texbin /usr/local/bin) bfname=$(dirname "$1")/"basename "$1" .tex" makeindex "$bfname".nlo -s nomencl.ist -o "$bfname".nls. I also experimented with giving the path to makeindex directly, but neither the content from the original post or any changes worked. – noumea May 11 '12 at 9:44

This might be a correct version of the Nomenclature.engine file:

#! /bin/bash
makeindex "$bfname".nlo -s nomencl.ist -o "$bfname".nls

In my tests it does the required call.


The code given by @egreg works for me. To answer other questions about where it goes, yes I put mine in ~/Library/TeXShop/Engines. If you make a copy of another engine, like XeTeX.engine (found in the same folder), rename it Nomenclature, and replace the contents with what egreg has provided, then you should be all set.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.