I have a problem with the MiKTeX package manager. I receive the message:

The MiKTeX web service has rejected your request. 
Possible reason: too many requests arriving from your IP address.


HTTP Error 503. The service is unavailable.

I cannot even choose another repository. Maybe this all was caused by my having killed the process on my first try with ctrl-alt-del? Can it be that at the server a "zombie" of that killed process is still present? Will the problem go away by itself?

  • I should add to my problem description that the exact problem was posted on latex-community.org/forum/viewtopic.php?f=9&t=1456. But no helpful advice was given there.
    – Wolfgang
    May 7, 2012 at 17:02
  • I'm having the same problem, looks like the server is down.
    – user14321
    May 7, 2012 at 17:52
  • I have the same problem. I think some server are down.
    – user14322
    May 7, 2012 at 17:53

4 Answers 4


Check the miktex.org site today for a status.

It's happening today, but it's intentionally down. Here's the reason today:

Problem with the latest update / package repository temporarily offline

The latest update (7/7/2015) mistakenly removes the package ltxbase (a quite essential part of the distribution). This will be fixed as soon as possible.

In the meantime, the MiKTeX package repository has been taken offline to prevent further distribution of the broken update.

  • Three spontaneous up-votes today are not a fluke. From miktex.org: "8/5/2015 Problem with the latest update / package repository temporarily offline" Aug 5, 2015 at 20:33
  • I logged this as a bug in the MikTeX bug tracker. Feel free to up-vote it there if you wasted a lot of time because of the obtuse error message. May 24, 2017 at 18:47

The MiKTeX packages are downloaded from are larger set of mirror servers. It appears that the one you got connected to is either down or doesn't accept multiple connections to him. Simply choose a different mirror from the mirror list and try again with it. Also simply waiting a little bit should fix it, because defect servers are automatically removed from the mirror list after a while or might recover.

  • 7
    Is "choosing a mirror" the same as "change the repository"? If so, I cannot do so, as the same error message appears. Could this problem maybe be related to the connection settings? Should I change something in the settings? Use a proxy?
    – Wolfgang
    May 7, 2012 at 18:50
  • Yes, mirror and repository is the same thing. If this doesn't help simply wait a day or so. Other people have the same issue, so it's not on your side. May 7, 2012 at 18:58
  • I will do so. Let's see tomorrow. Still, I am wondering if it could be related to the settings of my miktex or my computer. What is the intended use of the proxy settings in the "change package repository" menu anyway?
    – Wolfgang
    May 7, 2012 at 19:31
  • @Wolfgang: Some people are required to use proxies to connect to the internet, e.g. if they are being a company firewall etc. May 7, 2012 at 21:34
  • 1
    OK: I tried again this morning and everything worked fine this time. I could both install packages and change the package repository. Thanks for the help!
    – Wolfgang
    May 8, 2012 at 7:07

This is from the page MiKTeX Package Repository:

How it works

The primary package repository is a directory on my computer and its contents is not directly accessible from the Internet. From time to time (say once a week) I "release" the package directory by uploading its contents to the CTAN directory systems/win32/miktex, which is actually mirrored.

The MiKTeX web service is used by the MiKTeX package manager to retrieve the list of valid package repositories. In order to reduce resource usage on the server, the web service stalls (and possibly rejects) excessive requests arriving from the same IP address.

That means the rejections are made so as to reduce the load on the servers.


  1. If you can hide your IP (somehow!), then things should work as usual.
  2. If you can change your IP (you have to find a way if possible), then you are in business.
  3. Wait for some time, let us say minimum one day and then try.
  • I think in this case, it wasn't because of excessive requests.
    – svick
    May 8, 2012 at 12:31

Sadly I got the same prob. Just lay back an drink some tea. If you urgently need a package you can always manually download it via http://mirror.ctan.org/macros/latex/contrib. Dont forget to refresh the index with the MiKTeX setting tool if you do so.

  • Thanks! I followed your advice, which is ok in the meantime.
    – Wolfgang
    May 7, 2012 at 19:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.