0

I've have used figure* environment throughout all the article but suddenly stops working and i don't no way, it only shows some quotation marks.

Here a sample code, sorry for the not so clear question but it is urgent.

\documentclass[fleqn,10pt]{SelfArx} % Document font size and equations flushed left

\usepackage[english]{babel} % Specify a different language here - english by default

\usepackage{lipsum} % Required to insert dummy text. To be removed otherwise

\usepackage[font=small]{subcaption}

\usepackage{gensymb} % per fare il cerchiolino de gradi 

\usepackage{float} % per mettere le figure dove voglio

\setlength{\parindent}{0pt} %elimina il rientro quando vai a capo


\usepackage{multicol}% http://ctan.org/pkg/multicols

\begin{document}

\begin{figure*}[!h]

 \includegraphics[angle=90,scale=0.2]{FULL_STRUCTURE/DOMAIN_PATTERN/ciao}

\end{figure*}

\end{document}
4
  • Where did you get SelfArx.cls from? – leandriis Jun 9 '20 at 19:01
  • i'm using a template of a scientific article and that files comes with it – Andrea Jun 9 '20 at 19:08
  • 2
    unless you show us a link to the class it is impossible to say anything as there is no figure environment pre-defined its definition is always in the class. Note that two column floats do not have h option so [!h] specifies that the float is not allowed at top of the page or on a float page so it will not be allowed anywhere so will go to the end of the document (or \clearpage) – David Carlisle Jun 9 '20 at 19:41
  • It is also possible that the image is too big, which is why you should always include the [p] option. – John Kormylo Jun 10 '20 at 12:26
1

Do not put any options to the figure* environment, just plain \begin{figure*}. If you do provide an option then the figure will end up on the last page of the document.

For example:

% twocolfigprob.tex SE 548808
\documentclass[twocolumn]{article}
\usepackage{lipsum}
\usepackage{graphicx}
\usepackage{mwe}
\begin{document}
\lipsum[1-6]
\begin{figure*}
\centering
\includegraphics[angle=90, height=0.99\textheight,width=0.9\textwidth]{example-image}
\end{figure*}
\lipsum[1-6]

\end{document}

I was unable to process your MWE. I don't know the class that you are using, nor the particular graphic you are using so I have used the article class and one of the "standard" images from the mwe package.

2
  • yes i'm doing like that, but it does not work, maybe should I mention that I'm using \includegraphics[angle=90] , this angle option seems to cause the problem, but i don't know why – Andrea Jun 10 '20 at 17:57
  • @Andrea I have extended my answer for the general case. Perhaps the problem is with the SelfArx class (whatever that is). – Peter Wilson Jun 11 '20 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.