0

I'm getting the error message "!Undefined control sequence.\namepartfamily -> R{\dbend}cker \end" and am lost in what it means. It comes up when I try to load my bibliography (I'm using biblatex with bibtex as my backend). My bibliography is created via the BetterBibTex extension from Zotero and every entry looks like this:

  title = {title},
  author = {Name, surname},
  year = {year},
  volume = {volume},
  pages = {page--page},
  doi = {doi},
  abstract = {abstract},
  journal = {xx},
  language = {xx},
  number = {xx}
}

Running from:

\documentclass[paper=a4,oneside,BCOR=10mm,DIV=calc,pagesize=auto,bibliography=totoc,listof=totoc,numbers=noenddot,chapterprefix=on]{scrbook}
\input{preambel/preambel.tex}

\begin{document}

\input{content/title.tex}
\input{content/content.tex}

\begin{flushleft}
\printbibliography
\end{flushleft}

\end{document}

I already tried looking for the sequence mentioned in the error message in my .bib but to no avail. I'd be happy for some insight on what could be my mistake! Hope I didn't miss anything!

2
  • Do you have \usepackage{manfnt} in your preamble? It provides the \dbend definition. That said, not sure why \dbend would appear in a bib entry, where on might otherwise expect an umlauted u. Jun 10 '20 at 19:31
  • Thanks a bunch! It worked! Jun 10 '20 at 19:35
2

According to The Comprehensive LaTeX Symbol List \dbend is defined by the manfnt package. So you would load \usepackage{manfnt} to make \dbend work. See also Steven B. Segletes comment.

In this case it is, however, highly unlikely that \dbend is the actual command you are after. It looks more like an export/input error. Presumably the input to Zotero got messed up somehow (copy-and-paste encoding garbage) so that its (or Better BibTeX's) LaTeX converter now exports the wrong character. Double check your input for the relevant entries for non-ASCII chars.

Just for fun I Googled \dbend and found http://www.tg.uni-bonn.de/publications/talks/ where several German non-ASCII chars (ä, ö, ß) got converted to \dbend for some reason.

2
  • accents are dangerous things, need to be signposted:-) Jun 10 '20 at 20:18
  • BBT converts the unicode replacement character \uFFFD to \dbend. This is certainly an input error, the name in Zotero is R�cker, and the \dbend is just to signify that without aborting the export completely.
    – retorquere
    Jun 19 '20 at 19:01
1

The error message "!Undefined control sequence.\namepartfamily -> R{\dbend}cker \end" would seem to indicate \dbend is undefined. The latter originates in the manfnt package and represents the double-dangerous bend used by Knuth in the TeXbook. Place \usepackage{manfnt} in your preamble. It provides the \dbend definition.

That said, I am not sure why \dbend would appear in a bib entry, especially where on might otherwise expect an umlauted u, as in R{\"u}cker. Presumably, \dbend appears in one of the bibliography entries.

The OP has indicated that this remedy fixed the issue. The following MWE will generate the OP's error.

\documentclass[paper=a4,oneside,BCOR=10mm,DIV=calc,pagesize=auto,bibliography=totoc,listof=totoc,numbers=noenddot,chapterprefix=on]{scrbook}
\def\namepartfamily{R{\dbend}cker}
\begin{document}
\namepartfamily
\end{document}

enter image description here

1

If you get \dbend from BBT, that means there's an unicode character replacement character (U+FFFD) in the name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.