0

I'm writing a class paper with some shorthands that are so common I don't need any introduction to them in the first note.

biblatex-chicago has two ways to customize the shorthand intro, but I don't see a way to omit it for a particular entry.

There are two features listed to alter the entry, which by default is "(hereafter cited as shorthand)":

  • shorthandintro: (4.1 in the biblatex-chicago manual) Adding this to a bib entry replaces the default intro. When left blank, though, the default still appears. That is, shorthandintro = {}, has no effect.
  • shorthandpunct: (4.4.2 in the biblatex-chicago manual) This is an option that can be set for a whole document or for an entry, but I can't figure out the syntax for an individual entry. It controls the leading punctuation:

    The default is \addspace, but if this isn’t correct for your needs, especially if you change the shorthandintro or don't want the whole phrase inside parentheses, then you can change it in the preamble or in individual entries.

I've tried shorthand = none,, shorthand = {none},, and a few other things, but it doesn't work.

Is there a way to use these options to omit the shorthand introduction? I don't want to suppress the shorthand field and its other functionalities, just this introduction that appears at the first full citation.

3
  • By "class paper" I just mean it's for a class, i.e., the professor is familiar with these shorthands. I don't think my question is affected by what you're asking.
    – Norbert-op
    Jun 12, 2020 at 21:03
  • 1
    Is this related to your question tex.stackexchange.com/a/482099/91556 ?
    – hesham
    Jun 12, 2020 at 21:14
  • Yes, it is! Thank you for finding that. This is a good global solution for turning it off in the whole document: \renewbibmacro*{cms:shorthandintro}{}. I'm still interested in knowing how shorthandpunct is supposed to function in a bib entry.
    – Norbert-op
    Jun 12, 2020 at 22:30

1 Answer 1

1

Biber removes empty fields, so

shorthandintro = {},

will have the same effect as not giving any shorthandintro field at all. And if no shorthandintro field is present, biblatex-chicago uses the normal method to introduce the shorthand.

Here is a copy of cms:shorthandintro, the bibmacro responsible for introdcuing the shorthand, that makes the value none for shorthandintro special and suppresses the shorthand introduction in that case.

\documentclass[american]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[notes, backend=biber]{biblatex-chicago}

\renewbibmacro*{cms:shorthandintro}{% For changing the citedas phrase
  \iffieldundef{shorthand}%
    {}%
    {\iffieldundef{shorthandintro}%
       {\ifthenelse{\ifentrytype{jurisdiction}\OR\ifentrytype{legal}\OR%
          \ifentrytype{legislation}}%
          {\printtext[brackets]{%
             \bibstring{hereinafter}\addspace%
             \printfield{shorthand}}}%
          {\printtext[parens]{%
            \bibstring{citedas}\addspace%
            \printfield{shorthand}}}}%
       {\iffieldequalstr{shorthandintro}{none}
          {}
          {\printfield{shorthandintro}}}}}


\begin{filecontents}{\jobname.bib}
@manual{realcms,
  shorthand      = {CMS},
  shorthandintro = {none},
  title          = {The {Chicago} Manual of Style},
  date           = 2003,
  subtitle       = {The Essential Guide for Writers, Editors, and Publishers},
  edition        = 15,
  publisher      = {University of Chicago Press},
  location       = {Chicago, Ill.},
  isbn           = {0-226-10403-6},
}
\end{filecontents}
\addbibresource{\jobname.bib}
\addbibresource{biblatex-examples.bib}

\begin{document}
Lorem\autocite{realcms}
ipsum\autocite{kant:kpv}
dolor\autocite{sigfridsson}
sit\autocite{kant:kpv}
amet\autocite{sigfridsson}
consectur\autocite{realcms}.
\printbibliography
\end{document}

The Chicago Manual of Style: The Essential Guide for Writers, Editors, and Publishers, 15th ed. (Chicago, Ill.: University of Chicago Press, 2003), isbn: 0-226-10403-6.//Immanuel Kant, “Kritik der praktischen Vernunft,” in Kritik der praktischen Vernunft. Kritik der Urtheilskraft, vol. 5 of Kants Werke. Akademie Textausgabe (Berlin: Walter de Gruyter, 1968), 1–163 (hereafter cited as KpV).


There are several other alternatives if you don't like this method.

If you use the execute field to just empty the definition of cms:shorthandintro you'll need no additional code in your preamble whatsoever

@manual{realcms,
  shorthand      = {CMS},
  execute        = {\renewbibmacro*{cms:shorthandintro}{}},
  title          = {The {Chicago} Manual of Style},
  date           = 2003,
  subtitle       = {The Essential Guide for Writers, Editors, and Publishers},
  edition        = 15,
  publisher      = {University of Chicago Press},
  location       = {Chicago, Ill.},
  isbn           = {0-226-10403-6},
}

It would also be possible to implement an entry-level option to suppress the shorthand intro. But methods like that will be extremely similar to the shorthandintro = {none}, shown above.

5
  • The second method with execute is a per-entry solution that works for me. The first method with shorthandintro = {none}, prints "none" in the document. I'm using biblatex-chicago Version 1.0rc5 (beta), so maybe the new Version 2.0 from this April is different. I'm waiting to upgrade until I finish my current projects, but I'll test it when I do.
    – Norbert-op
    Jun 14, 2020 at 12:58
  • @Norbert-op I'm assuming you also copied the \renewbibmacro*{cms:shorthandintro} for the first solution with shorthandintro = {none},, right? I can't be too sure, since I'm running biblatex-chicago 2.0 and don't have easy access to older versions, but at least tex.stackexchange.com/q/482083/35864 suggests we are redefining the right macro, so it surprises me that you still see "none" printed in the output. (Can you add some text like "AAA" to the beginning of the redefinition in \renewbibmacro*{cms:shorthandintro} and check if the AAA appears in the output?)
    – moewe
    Jun 14, 2020 at 13:06
  • @Norbert-op The redefinition of cms:shorthandintro is an integral part of the first attempt (the one with shorthandintro = {none},). But it definitely should not suppress all shorthands. Only those of entries with shorthandinto = {none}, (as shown in the image).
    – moewe
    Jun 14, 2020 at 13:18
  • @Norbert-op Oh, there was a very embarrassing typo in the code (\iffieldequalstr{none} should have been \iffieldequalstr{shorthandintro}{none}). Try again, please.
    – moewe
    Jun 14, 2020 at 13:22
  • Yes, it now works as expected: custom entries display their text, and "none" suppresses the default shorthandintro. I prefer the second solution, though, because it's easier to copy from one project to another. Thanks for your help.
    – Norbert-op
    Jun 14, 2020 at 13:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .