For a large lecture (600+ slides) I need ToC slides that show the ToC only for the current section, including all subsections and subsubsections.

However, apparently this does not work. When I pass the sections={<number>} option to \tableofcontents, the result is a ToC that shows all subsections, but only the subsubsections of one subsection. In the MWE this is always the content of the first subsubsection, but in my larger lecture slides document, it is (for whatever reason) always the second subsubsection.

When I remove the sections option, everything works as expected.

Is this a bug? (I have tried beamer version 3.10. as well as the recent version 3.17)

% def\beamer@version{3.10}

    \tableofcontents[subsectionstyle=show/show/show, subsubsectionstyle=show/show/show, #1]


\section{Lecture 1}

\InsertToC[sections={\thesection}]  % shows only subsubsections of one subsection
\subsection{Topic 1}

\subsection{Topic 2}
\InsertToC                         % shows subsubsections of all subsections 


Output of \tableofcontents with sections option (unexpected):

enter image description here

Output of \tableofcontents without sections option (expected):

enter image description here

closed as off topic by Marco Daniel, Joseph Wright Aug 5 '12 at 9:55

Questions on TeX - LaTeX Stack Exchange are expected to relate to TeX, LaTeX or related typesetting systems within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here. If this question can be reworded to fit the rules in the help center, please edit the question.

  • There are various inconsistencies in beamer regarding \subsubsections, as Till was clearly not keen on their use in presentations. I have addressed some of these over the past few months: could you try the very latest beamer release (3.17)? – Joseph Wright May 8 '12 at 16:52
  • @JosephWright: I had tried cloning the mercurial repo, but failed to use it as it contains all this unexpanded \ProvidePackageRCS $Header$ stuff. – Daniel May 8 '12 at 18:45
  • @JosephWright: Oh, I just saw that 3.17 is available on CTAN. Nice! (I didn't look there, as in the past only very few beamer releases made it actually there. Seems that things have changed a bit since you have become a maintainer :-) – Daniel May 8 '12 at 18:46
  • @JosephWright: I have tested with 3.17; the problem remains :-/ – Daniel May 8 '12 at 18:59
  • @JosephWright: How should I proceed from here? Can you confirm this to be a bug? Should I report it on the project`s bugtracker? – Daniel May 14 '12 at 20:35