0

Yesterday I ran the Miktex update on both admin and non-admin (on Windows 10), but now when I run a latex file, it asks to run the package manager, and cannot find any packages.

So I tried updating Miktex and get the error "Sorry but something went wrong, couldn't connect to server".

So I tried re-installing Miktex but the download fails "This site can’t be reached, mirror.aarnet.edu.au took too long to respond." This also happens on my android. But http://www.websitenotworking.com/miktex.org says Miktex is working! I tried disabling my firewall and ad-blocker temporarily but this made no difference. What should I do?

  • 2
    Maybe change repository? – Bernard Jun 16 at 20:57
  • I changed to some German repository, that managed to at least install one package..., are there any particularly reliable repositories? – Matt Majic Jun 16 at 21:38
  • Personally, I use distrib-coffee.ipsl.jussieu.fr which is a French university (in Paris). But ftp.dante.de is quite fast too. – Bernard Jun 16 at 21:50
  • I have the same error. "Bad request" "code="7", url="api2.miktex.org/hello" while checking for updates. Maybe somthings wrong with the server. – Guest Jun 17 at 7:54
  • After changing the repository, I could then download miktex from miktex.org (weird), and reinstall from scratch. It now works fine. – Matt Majic Jun 18 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.