1

I am using LaTeX with

\usepackage{cite}
\usepackage[super, square, comma]{natbib}

I want to get the citation call-outs in the form of

AA^{1, 6}

But right now I am getting

AA^{1,6}

i.e. without space after the comma. If I add the space option while loading natbib like this -- \usepackage[super, square, comma, space]{natbib} -- then my document can't be compiled.

1
  • Welcome to TeX.SE.
    – Mico
    Jun 17 '20 at 8:45
4

Your write-up isn't entirely clear since the code fragment you've posted appears to attempt to load the mutually incompatible cite and natbib packages. However, since you've also set the natbib tag, I will assume that you're really looking for a natbib-based solution.

If this assumption is correct, all you need to do is replace

\usepackage[super, square, comma]{natbib}

with

\usepackage[super,square]{natbib}
\setcitestyle{citesep={,\kern1.5pt}}

Feel free to adjust the amount of kerning to meet your aesthetic preferences.

enter image description here

\documentclass{article}
\begin{filecontents}[overwrite]{mybib.bib}
@misc{A,author="A",title="{AAA}",year=3001}
@misc{B,author="B",title="{BBB}",year=3002}
\end{filecontents}

\usepackage[super,square]{natbib}
\setcitestyle{citesep={,\kern1.5pt}}
\bibliographystyle{plain}

\begin{document}
AA\cite{A,B}
\bibliography{mybib}
\end{document}
2
  • Thank you for helping me it's work. Thanks a lot 😊
    – jhon
    Jun 18 '20 at 2:36
  • 1
    I did it as it solved my problem in good way.
    – jhon
    Jun 18 '20 at 6:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.