1

I have seen this question that looks similar, but it doesn't have a clear answer.

I am using the apa6 class to write a paper in the APA format. However, I need to use a less verbose citation style (for e.g. ACM) instead of the usual APA style.

Since the apa6 class automatically sets the style for citations, how do I override the default?

Currently, my preamble has the following:

\documentclass[a4paper,man, natbib]{apa6}

Adding

\bibliographystyle{stylename} and changing stylename to something else like plainnat or ksfh_nat isn't helping.

Appreciate any suggestions.

1

You wrote:

Since the apa6 class automatically sets the style for citations ...

This claim isn't quite correct. If you load the apa6 document class without one of the options biblatex, apacite, or natbib, no citation management package is loaded and no bibliography style is chosen.

Here's an excerpt from page 10 of the user guide of the apa6 document class (highlighting added):

enter image description here

Maybe slightly counterintuitively, then, in order to achieve your formatting objectives you should not specify the natbib option while executing \documentclass, since doing so loads the apacite citation management package and the apacite bibliography style -- which is precisely what you don't want to do.

What to do? (a) Drop the natbib option from the \documentclass directive, (b) load natbib along with suitable options via a \usepackage statement, and (c) issue a suitable \bibliographystyle directive. For instance,

\usepackage[numbers]{natbib} % numeric-style citation call-outs
\bibliographystyle{acmtrans} % or some other suitable bib style

A full MWE (minimum working example) and its output:

enter image description here

\documentclass{apa6}

% Create a bib file "on the fly"
\begin{filecontents}[overwrite]{mybib.bib}
@misc{aa:3001,author="Anne Author",title="Thoughts",year=3001}
\end{filecontents}

\usepackage[numbers]{natbib}
\bibliographystyle{acmtrans} % or some other suitable bib style

\begin{document}
\cite{aa:3001}
\bibliography{mybib}
\end{document}
  • that isn't working for me. I get ? ? ? in the references. – wrahool Jun 18 '20 at 5:19
  • @wrahool - Did you also perform a full recompile cycle -- latex, bibtex, and latex twice more -- after applying the suggested changes? How do you load the natbib package, and which bibliography style do you employ? – Mico Jun 18 '20 at 5:20
  • My first three lines in the preamble are as follows: \documentclass[a4paper,man]{apa6} \usepackage[numbers]{natbib} \bibliographystyle{acmtrans} And yes, I did a full compile cycle twice over (FWIW, I'm doing this on Overleaf not on my desktop client) – wrahool Jun 18 '20 at 5:24
  • 1
    @wrahool - With your code, you should be getting several warning and error messages, such as a complaint about \shorttitle not being defined. Don't ignore such messages. Specifying the man option tells LaTeX to execute, among other things, \RequirePackage[natbibapa,bibnewpage]{apacite}. This clashes with the subsequent \usepackage[numbers]{natbib} directive. That's not what you want, is it? The solution: don't specify the man option. – Mico Jun 18 '20 at 5:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.