5

I am working on a college project and to be specific we are using Another's template in Overleaf. so I don't know that much about LaTeX or Overleaf. There is an error showing up:

/usr/local/texlive/2019/texmf-dist/tex/latex/lineno/lineno.sty Command @parboxrestore has changed.

I read about the posts about this problem, they are saying to place \usepackage{csquotes} before using package lineno. Now the problem is that there is no line like \usepackage{csquotes} in main.tex.

The packages are:

\documentclass[12pt, a4paper, oneside]{Thesis} % Paper size, default font size and one-sided paper
\usepackage{wrapfig}
\usepackage{lscape}
\usepackage{rotating}
\usepackage{graphicx}
\usepackage{caption}
\usepackage{amsmath}
\usepackage{graphics}  
 
 
 
\usepackage{tikz}
\usetikzlibrary{shapes.geometric, arrows}
\tikzstyle{startstop} = [rectangle, rounded corners, minimum width=3cm, minimum height=2cm,text centered, draw=black, fill=red!30]

\tikzstyle{io} = [trapezium, trapezium left angle=70, trapezium right angle=110, minimum width=3cm, minimum height=1cm, text centered, draw=black, fill=blue!30]











\tikzstyle{process} = [rectangle, minimum width=5cm, minimum height=2cm, text centered, draw=black, fill=orange!30]

\tikzstyle{decision} = [diamond, minimum width=5cm, minimum height=2cm, text centered, draw=black, fill=green!30]

\tikzstyle{arrow} = [thick,->,>=stealth]

\usepackage{lineno,hyperref}
\usepackage{csquotes}
\modulolinenumbers[5]

\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{graphicx}
\usepackage{array}
\usepackage{float}
\usepackage{placeins}
\usepackage{stackengine}
\usepackage{url}
\usepackage{numprint}
\usepackage{caption}

\usepackage{booktabs}  
\usepackage{siunitx}
%\usepackage[showframe=false]{geometry}
\usepackage{subfigure}



\usepackage[utf8]{inputenc}
\usepackage{amssymb}


\usepackage[english]{babel}
\usepackage[utf8]{inputenc}
\usepackage{algorithm}
\usepackage[noend]{algpseudocode}





\nprounddigits{3}
\newcolumntype{P}[1]{>{\centering\arraybackslash}p{#1}}
\newcolumntype{M}[1]{>{\centering\arraybackslash}m{#1}}

\setstackEOL{\#}
\setstackgap{L}{12pt}


%\usepackage{subcaption} %incompatible with subfig
\graphicspath{{Pictures/}} % Specifies the directory where pictures are stored
\usepackage{natbib} % Use the natbib reference package - read up on this to edit the reference style; if you want text (e.g. Smith et al., 2012) for the in-text references (instead of numbers), remove 'numbers' v

How can I solve this?

2
  • Where is the Thesis class available?
    – egreg
    Jun 19, 2020 at 8:39
  • Thank you sir I got it Jun 21, 2020 at 18:58

1 Answer 1

6

I placed \usepackage[pagewise]{lineno} before \usepackage{csquotes} and the error message disappeared, exactly the opposite of what was suggested by the references looked at by the OP.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .