1

Related to my other question: I cite in my text using footnotes and have the bibliography sorted by date. I need the reflist option in windycity to ensure that the bibliography is sorted by date and has the date immediately following the author. When I cite works from the same author from the same year, letters are added behind the year in the bibliography. This makes sense for inline author-date citations, but not for notes citations. Can I prevent this from happening?

MWE:

\documentclass{article}
\usepackage[reflist=true, style=windycity, date=year]{biblatex}
\bibliography{biblatex-examples}
\begin{document}
    \cite{knuth:ct:c}
    
    \cite{knuth:ct:b}   
    \printbibliography
\end{document}

enter image description here

2
  • 3
    Does this answer your question? Suppress year label letter in biblatex author-year styles on a per-bibliography or per-keyword basis
    – DG'
    Commented Jun 19, 2020 at 12:11
  • 1
    I voted not to close the question as a duplicate since the other question specifically was about suppressing the extradate info per-bibliography in case there are multiple bibliographies in a document. If one wants to suppress the extardate info for all bibliographies (for example because there is only one), then there are other, simpler solutions.
    – moewe
    Commented Jun 19, 2020 at 14:00

2 Answers 2

2

The conceptually nicest way to get rid of the extradate field/the disambiguation letter after the year is to tell biblatex not to calculate the labeldate at all by passing the option labeldateparts=false.

But windycity assumes labeldateparts=true and does not work properly if the option is set to false.

So here is the next best workaround that suppresses the field extradata (and the companion field extradatescope) as they are read from the .bbl file.

\documentclass{article}
\usepackage[reflist=true, style=windycity, date=year]{biblatex}
\addbibresource{biblatex-examples.bib}

\DeclareFieldInputHandler{extradate}{\def\NewValue{}}
\DeclareFieldInputHandler{extradatescope}{\def\NewValue{}}

\begin{document}
  \cite{knuth:ct:c}

  \cite{knuth:ct:b}
  \printbibliography
\end{document}

Knuth, Donald E. 1986. TeX: The Program. Vols. B of Computers & Typesetting. Reading, Mass. Addison-Wesley.

Of course that means the extradate is really gone and \parencites are no longer unique.

If you want the letters gone only in the bibliography, use

\AtEveryBibitem{%
  \clearfield{extradate}%
  \clearfield{extradatescope}}
1

Answering to your edit:

You can modify the environment using the code form here: https://tex.stackexchange.com/a/63865/29873

\documentclass{article}
\usepackage[reflist=true, style=windycity, date=year]{biblatex}
\bibliography{biblatex-examples}

\defbibenvironment{nodis}
  {\list
     {}
     {\setlength{\leftmargin}{\bibhang}%
      \setlength{\itemindent}{-\leftmargin}%
      \setlength{\itemsep}{\bibitemsep}%
      \setlength{\parsep}{\bibparsep}}}
  {\endlist}
  {\clearfield{extradate}\item}

\begin{document}
    \cite{knuth:ct:c}
    
    \cite{knuth:ct:b}   
    \printbibliography
    \printbibliography[env=nodis]
\end{document}

enter image description here


From the manual:

reflist

Use this option to print a bibliography in the author-date format, what CMOS calls a reference list.

If you don't want that format, don't use that option:

\documentclass{article}
\usepackage[style=windycity, date=year]{biblatex}
\bibliography{biblatex-examples}
\begin{document}
    \cite{knuth:ct:c}
    
    \cite{knuth:ct:b}   
    \printbibliography
\end{document}

enter image description here

1
  • As I mentioned in my question, I need the bibliography to be sorted by date. I need reflist is the way to achieve that. I have rephrased the question to make that more clear.
    – cktai
    Commented Jun 19, 2020 at 10:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .