1

I think I've read all posts concerning this issue and a solution might have been provided but I don't understand it.

Here is the full story.

I export my bibliography file from Zotero (I tried everything BibTex, BibLaTex, UTF-8 and Western, all possible combinations).

I work in Texniccenter editor.

I would like to use biblatex (the example is not full, it's a thesis normally, so too long).

Here is my code:

\documentclass{book}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[french]{babel}
\usepackage{csquotes}
\usepackage[backend=biber]{biblatex}
\addbibresource{bibli}
\title{YYY}
\author{\textsc{ZZZ}}
\date{\today}
\begin{document}
\maketitle
\frontmatter
\tableofcontents
\chapter{Introduction}
\mainmatter
\part{State of the art}
\chapter{blabla}
L'intérêt pour l'activité d'abattage a été étudié à plusieurs reprises en sciences sociales. Toutefois, la condition animale en elle-même y est très peu abordée, sans doute parce que les acteurs de terrain eux-mêmes la considère comme un non-sujet \cite{muller_a_2008}.
\printbibliography
\addcontentsline{toc}{chapter}{Bibliographie}
\end{document}

Here is a part of my bibliography file:

@book{muller_a_2008,
    address = {Paris; Versailles},
    title = {{\'A} l'abattoir: travail et relations professionnelles face au risque sanitaire},
    isbn = {978-2-7351-1170-1 978-2-7592-0051-1},
    shorttitle = {{\'A} l'abattoir},
    language = {French},
    publisher = {{\'E}ditions de la Maison des sciences de l'homme ; {\'E}ditions Quae},
    author = {Muller, S{\'e}verin},
    year = {2008},
    note = {OCLC: 262718567}
}

Probably the answer is simple, but I am quite new, and yes, I really read a lot of documentation, without finding anything useful.

I also tried to change the settings of output profile (use biber instead of bibtex) but it did not work.

Problem might come from Zotero? If so how to know where cause my file is super long?...

10
  • 1
    if latex tells you to rerun biber, that means that you either didn't run biber at all (but e.g bibtex instead), or that you did run biber but that there was an error. Find the .blg-file in your folder, open it in your editor and check what it says. Jun 29, 2020 at 14:22
  • Note that if you are a new user texniccenter might not be a good editor to use: (1) it does not seem to have been updated since 2014, (2) it does not come with its own PDF viewer, and thus jumping back and forth between texniccenter and he PDF is something you have to set up manually. Might be worth checking texmaker or texstudio (they look similar but texstudio has more features). AFAIR both texmaker and texstudio have build in configurations to switch to biber.
    – daleif
    Jun 29, 2020 at 14:31
  • [0] Config.pm:304> INFO - This is Biber 2.14 [0] Config.pm:307> INFO - Logfile is 'These.blg' [105] biber-MSWIN64:322> INFO - === [129] Biber.pm:415> INFO - Reading 'These.bcf' [279] Biber.pm:943> INFO - Found 31 citekeys in bib section 0 [313] Biber.pm:4256> INFO - Processing section 0 [314] Utils.pm:75> INFO - Globbing data source 'bibli' [340] Utils.pm:91> INFO - Globbed data source 'bibli' to bibli [381] Biber.pm:4455> INFO - Looking for bibtex format file 'bibli' for section 0 [1001] Utils.pm:320> ERROR - Cannot find 'bibli'! [1002] Biber.pm:132> INFO - ERRORS: 1
    – Anne-Laure
    Jun 29, 2020 at 14:38
  • 2
    Try \addbibresource{bibli.bib} (with the .bib extension). Jun 29, 2020 at 14:55
  • THANKS! I feel stupid now...
    – Anne-Laure
    Jun 29, 2020 at 14:58

1 Answer 1

1

The Biber error message is clear: ERROR - Cannot find 'bibli'!

Use \addbibresource{bibli.bib} (with the .bib extension) instead of \addbibresource{bibli}.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.