5

After Sunday June 28 massive update, miktex started working bad namely both latex and pdflatex working in total crash way (no interaction at all, with no hint of mistake). Today, I tried to reinstall miktex twice and it came from bad to worse with absolute total disfunctionality. Any latex run ends with

Sorry, but C:\PROGRA~1\MiKTeX\miktex\bin\x64\latex.exe did not succeed.
The log file hopefully contains the information to get MiKTeX going again:
  C:\Users\vov\AppData\Local\MiKTeX\miktex\log\latex.log
OxEdit: module reports errors!!! 

latex.log says (47mm3.tex is the file, but the crash happens with any file). Aditionally, after a compulsory update upon the installation, the consone update also crashes, returning "Configuration error: no conversion from undefined configuration value to string."

2020-06-30 08:17:16,444+0300 INFO  latex - this process (3164) started by 'OxEdit' with command line: C:\PROGRA~1\MiKTeX\miktex\bin\x64\latex.exe 47mm3
2020-06-30 08:17:16,444+0300 INFO  latex - allowing known shell commands
2020-06-30 08:17:16,444+0300 INFO  latex - enabling input (output) from (to) processes
2020-06-30 08:17:16,629+0300 FATAL latex.core - GUI framework cannot be initialized.
2020-06-30 08:17:16,629+0300 FATAL latex.core - Data: 
2020-06-30 08:17:16,629+0300 FATAL latex.core - Source: Libraries\MiKTeX\UI\Qt\mikuiqt.cpp:77
2020-06-30 08:17:16,629+0300 FATAL latex - GUI framework cannot be initialized.
2020-06-30 08:17:16,629+0300 FATAL latex - Info: 
2020-06-30 08:17:16,629+0300 FATAL latex - Source: Libraries\MiKTeX\UI\Qt\mikuiqt.cpp
2020-06-30 08:17:16,629+0300 FATAL latex - Line: 77
2020-06-30 08:17:16,629+0300 INFO  latex - this process (3164) finishes with exit code 1
2020-06-30 08:17:16,629+0300 WARN  miktex.core - still open: 47mm3.tex
2020-06-30 08:17:16,629+0300 WARN  miktex.core - still open: 47mm3.log

Any remedy? I have just started to install texlive, looking to take a full day or more, but I got accustomed to miktex ...

6
  • Go to the MiKTeX issue tracker. The bug has been reported and there you can find or ask for advice how to repair MiKTeX. Jun 30, 2020 at 6:25
  • @UlrikeFischer I couldn't find any open or recently closed issue related to this 'no conversion from undefined configuration value to string' error in MiKTeX console. I didn't yet dare to run pdflatex.exe, but guess that miktex-console.exe might be causing another issue not directly related to pdflatex.exe/latex.exe? Started a new issue here.
    – tstone-1
    Jun 30, 2020 at 8:15
  • Have you tried to run latex at the command-line prompt? For example: pdflatex.exe 47mm3 Jun 30, 2020 at 8:57
  • over a simple file like \documentclass{article}\begin{document}XXX\end{document} Jun 30, 2020 at 11:19
  • over a simple file like \documentclass{article}\begin{document}XXX\end{document} pdflatex works, But 1) if I add something problematic like an undefined macro like \xxx - it crashes w/o any pdf created and w/o any attempt to discuss a fix, and 2) updates are disabled, so requested packages cannot be loaded and it crashes at first stop of any kind. So miktex is disfunctional now on my desktop. I was fortunate not to update miktex on my laptop. Jun 30, 2020 at 11:27

0

Browse other questions tagged or ask your own question.