0

When I attempt to typeset LaTeX I get the dialogue box pop up "Can't find required tool" and I copy and paste here the rest: "/Library/TeX/texbin /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/matplotlib/tests/baseline_images/test_backend_pgf/pgf_pdflatex.pdf /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/matplotlib/tests/baseline_images/test_backend_pgf/pdflatex does not exist. TeXShop is a front end for TeX, but you also need a TeX distribution. Perhaps such a distribution was not installed or was removed during a system upgrade. If so, go to http://tug.org/mactex and follow the instructions to install MacTeX or BasicTeX."

Running pdflatexmk I get the following in the console:

Latexmk: This is Latexmk, John Collins, 18 June 2019, version: 4.65.
Rule 'pdflatex': File changes, etc:
   Changed files, or newly in use since previous run(s):
      'QFT.tex'
------------
Run number 1 of rule 'pdflatex'
------------
------------
Running 'pdflatex  --synctex=1 --file-line-error  -recorder  "QFT.tex"'
------------
Latexmk: applying rule 'pdflatex'...
sh: pdflatex: command not found
Latexmk: fls file doesn't appear to have been made.
Collected error summary (may duplicate other messages):
  pdflatex: Command for 'pdflatex' gave return code 127
      Refer to 'QFT.log' for details
----------------------
This message may duplicate earlier message.
Latexmk: Failure in processing file 'QFT.tex':
   (Pdf)LaTeX didn't generate the expected log file 'QFT.log'
----------------------
Latexmk: Use the -f option to force complete processing,
 unless error was exceeding maximum runs, or warnings treated as errors.
Latexmk: Errors, so I did not complete making targets

I have tried uninstalling TeXShop (deleting all related files too) and reinstalling, but I always get the same error. It seems to me that it is trying to find pdflatex in a strange location involving a file from another program - This "python.framework" thing, but I haven't told it to do so. In fact, in the preferences menu, under "engine", the path it is being told to follow to find pdflatex is the default one - /Library/Tex/bin. I can find no references to this Python file in any of the settings available to me to change it.

I can see a lot of people have had similar issues, but people always say to uninstall and reinstall, but this hasn't worked for me (I've done it 3 times) and I have also tried the other most popular solutions, but to no avail. I have also tried BasicTex, but this program didn't seem to run properly for me (I think unrelated to this problem, though).

I am running macOS Catalina, if this is needed.

1
  • Did you install a TeX Distribution? Latexmk is built into TeXShop but pdflatex is part of a TeX Distribution. If you haven’t yet installed one I suggest. MacTeX. – Herb Schulz Jun 30 '20 at 14:26
1

Re-installing TeXShop will NOT solve your problem. You need a TeX Distribution (latexmk is built into TeXShop but pdflatex and friends are part of a distribution). I suggest getting <MacTeX> which will install the TeX Live 2020 distribution. Please read the documentation you end up with in /Applications/TeX and download and install TeX Live Utility.

0

For those who may experience a similar problem, I post my solution here. Uninstalling isn't enough - as a lot of programs do, TexShop has a lot of files hidden everywhere holding your preferences and caches that simply uninstalling the program won't delete. To delete all relevant files I recommend following the instructions given here: https://macuninstallguides.com/remove-texshop-on-mac.html Once I did this and reinstalled, it worked! I can finally continue my thesis.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.