I've updated the MiKTeX Console on admin this morning with all of the new updates. After this update, I haven't been able to do anything within the console. I've tried installing packages which fails and gives the following error: Configuration error: no conversion from undefined configuration value to string.

This error occurs for both installing packages and checking updates. I've tried the suggestion for similar issue located here which suggests inputting the following code into command line to launch the program but that doesn't resolve this issue. One potential reason is that I need to change to admin privileges once I'm inside the MiKTeK console which may cause it to restart and lose the location set below.

set MIKTEX_REMOTESERVICEOFKLT=https://api2.miktex.org/ miktex-console

  • Actually, this symptom has last at least two days. Jul 2, 2020 at 1:45
  • If you need to update in Admin mode I found that opening the terminal/command line as Admin (on Win 10 type "cmd" into the search bar, then right-click on the terminal and select "open as admin" [or some such]) and pasting the code works. You will still be asked on startup of the MikTeX Console if you want to be user or Admin, but when you select "Admin" you can proceed to update without errors (even when the MikTeX Console restarts).
    – moewe
    Jul 2, 2020 at 6:25

1 Answer 1


I Run windows 10 and I had the same problem and I solved it in a radical way. I am not sure whether it is the optimal way to solve it but I simply reinstalled MiKTeX. Of course first I backed up all my personal configuration and style files. In case it helps here is what made me take this decision: My thought was that it had to do with the recent change in the naming of MiKTeX and by looking at Programs and Features I saw there were two entries, one named MiKTeX and one named MiKTeX 2.9. This somehow made me believe that the "console was confused" and so, given I did not know any other way of exploring the nature of the problem in depth, I decided to reinstall by uninstalling first.

Now it works fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .