0

I need to draw a number of lines in a document. Since I may want to change the format of all the lines, I wrote a newcommand (this is only my second attempt at writing my own command). When I highlight the whole of the MWE below and run "compile selected" in WinEdit, everything works. But if I run PDFTeXify I get an error

! LaTeX Error: \begin{flexlabelled} on input line 33 ended by \end{quote}.

I am mystified.

EDIT: I tried changing the [2] in the \quotesep command to a [1] and got the same error.

MWE

\documentclass{memoir}
% \let\providelength\relax
\title{Interesting words}
\author{Peter Flom}
% \usepackage{hyperref}

\usepackage[marginpar]{todo}
\usepackage{url}
\usepackage{varioref}
\usepackage{ellipsis}

%% A convenience command, for typesetting the
%% word and pronunciation

%\newcommand{\entry}[2]{\medskip\noindent{\Large\textbf{#1} (#2)\par}}
\newcommand{\entry}[2]{\medskip\noindent{\Large\textbf{#1} \normalsize{#2} \par}}



%\newcommand{\sclabel}[1]{\normalfont\scshape #1}
\newcommand{\sclabel}[1]{\leavevmode{\normalfont\scshape #1}}
%% Less spacing around lists
\firmlists

%\newcommand{\quotesep}[1]{\rule{3in}{1pt}}
\newcommand{\quotesep}[2]{\rule{3in}{1pt}{\hfill}}

    \begin{document}
    
    
    
          \entry{Anonym[e]}{Pronunciation} %On Medium From Jones p. 271 other
             \begin{flexlabelled}{sclabel}{0pt}{0.5em}{0.5em}{*}{\leftmargin}
             \item[Definition]
             \textit{n.} A person who wishes to remain anonymous.
             \item[Etymology]
             Starting with Greek \textit{anonymous} through Latin and French.
             \item[Anti-thesaurus]\leavevmode
             \begin{description}
               \item[Incognita] -- which is a girl or woman who is unknown or disguised.
             \end{description}
             \item[Usage]
             We certainly need a word for this type of person! Everyone knows the word anonymous, but what about the person desiring anonymity?
             \item[Examples]  \leavevmode
               \epigraphwidth 3.5in
                 \epigraphrule 0pt
                  \epigraph{%
                      I should hardly risk a contest with all the anonymes \& synonymes of the Committee candidates.}{%
                \textit{Letter}\\ George Gordon Noel Byron}
               \quotesep
               \begin{quote} \hfill \\
                 Until relatively recently, many female science fiction authors were anonyms, believing that prejudice against women would hurt their sales if they used their true names.
               \end{quote}
             \item[Frequency]
             About 1 in 20 million words.
           \end{flexlabelled} \vspace{0.5in}
    
    \end{document} 
  • 5
    your \quotesep command takes two arguments and so is eating the \begin{quote}. – Ulrike Fischer Jul 2 at 12:05
  • I tried changing the [2] in \quotesep to a [1] and got the same error. – Peter Flom Jul 2 at 13:04
  • 2
    Your command has zero arguments, so remove the [1] completly. – Ulrike Fischer Jul 2 at 13:11
  • Thanks! That works. – Peter Flom Jul 2 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.