0

My footnotes are showing up in the outer margins but I want them only to show up in the right margins. How can I do this?

\documentclass{book}

\usepackage[right=7cm]{geometry}
\usepackage[side, flushmargin]{footmisc}

\begin{document}

Lorem Ipsum is simply dummy text of the printing and typesetting industry. Lorem Ipsum has been the 
industry's standard dummy text ever since the 1500s, when an unknown printer took a galley of type and scrambled it to make a type specimen book. It has survived not only five centuries\footnote{testing}, but also the leap into electronic typesetting, remaining essentially unchanged. It was popularised in the 1960s with the release of Letraset sheets containing Lorem Ipsum passages, and more recently with desktop publishing software like Aldus PageMaker including versions of Lorem Ipsum.

\newpage

Lorem Ipsum is simply dummy text of the printing and typesetting industry. Lorem Ipsum has been the industry's standard dummy text ever since the 1500s, when an unknown printer took a galley of type and scrambled it to make a type specimen book. It has survived not only five centuries, but also the leap into electronic typesetting, remaining essentially unchanged. It was popularised \footnote{testing} in the 1960s with the release of Letraset sheets containing Lorem Ipsum passages, and more recently with desktop publishing software like Aldus PageMaker including versions of Lorem Ipsum.

\end{document}
0

If you are using \documentclass[twoside]{book}, you can use etoolboxpackage:

\usepackage{etoolbox}
\makeatletter 
\patchcmd{\@addmarginpar}{\ifodd\c@page}{\ifodd\c@page\@tempcnta\m@ne}{}{}
\makeatother
\reversemarginpar 

(To shift your notes to the left margin just comment \reversemarginpar)

1
  • The book class is twoside by default, so your solution works without adding it as an option. It turns out that what I wanted was the oneside option (which your solution brought to my attention) so the outer margin doesn't alternate. Then I didn't need to change anything.
    – E2R0NS
    Jul 3 '20 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.