Could you please recommend how can i set PDFLatex Document font to Sylfaen for Georgian language.
Below is my current setup which doesn't work.
\documentclass [a4paper, georgian, 12pt]{article}

\renewcommand\rmdefault        {sylfaen}
\renewcommand\familydefault    {\rmdefault}

As it's an truetype font it would be easiest to use lulatex or xelatex I get this with lualatex

enter image description here

\documentclass [a4paper, georgian, 12pt]{article}


Გამარჯობა მსოფლიო

The first character is apparently not available in the font, the log warns:

Missing character: There is no Გ (U+1C92) in font [sylfaen.ttf]:mode=node;scri

oh script=latn is probably wrong, it may be better if I gave a better script tag.

| improve this answer | |
  • Thank you! Actually it works. The Missing character error is due to capitalization. The only question which i have now is about the letter tracking. I used \usepackage[letterspace=25]{microtype} Which seems not affecting anymore on this font. Any Idea how can it be fixed. Thanks in advance – ussrback Jul 4 at 18:38
  • fontspec can specify letterspacing directly to the font without microtype try adding ,LetterSpace=10 to the argument above – David Carlisle Jul 4 at 18:50
  • You can get the missing-character warning in the console, instead of silently logged, with \tracinglostchars=2. – Davislor Jul 5 at 5:24
  • In 2020, you also probably want Renderer=Harfbuzz instead of the raw feature. Or the default might work. – Davislor Jul 5 at 5:26
  • You would want to set the main font with something like \babelfont{rm}[Scale=1.0]{Sylfaen}, with additional options following Scale= as needed. This will set the correct OpenType script and language tags for the current language. – Davislor Jul 5 at 5:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.