1

I get an error with the letter ì but not with the other accented letters àèòù, I post the preamble below (Look the EDIT below, the code that I posted doesn't matter):

\documentclass[10pt, aspectratio=1610]{beamer}

\usepackage{media9}
\usepackage{amssymb,amsmath,amsthm,enumerate}
\usepackage[utf8]{inputenc}
\usepackage{array}
\usepackage[parfill]{parskip}
\usepackage{graphicx}
\usepackage{caption}
\usepackage{subcaption}
\usepackage{bm}
\usepackage{amsfonts,amscd}
\usepackage[]{units}
\usepackage{listings}
\usepackage{multicol}
\usepackage{multirow}
\usepackage{tcolorbox}
\usepackage{physics}
\usepackage{svg}
\usepackage{dsfont}
\usepackage{tikz}
\usetikzlibrary{shapes.geometric}

\newcommand\paraitem{%
 \quad
 \makebox[\labelwidth][r]{%
 \makelabel{%
 \usebeamertemplate{itemize \beameritemnestingprefix item}}}\hskip\labelsep}

\newcommand\NoIndent[1]{%
    \par\vbox{\parbox[t]{\linewidth}{#1}}%
}

% Enable colored hyperlinks
\hypersetup{colorlinks=true}
\hypersetup{linkcolor=orangeEX}

% The following three lines are for crossmarks & checkmarks
\usepackage{pifont}% http://ctan.org/pkg/pifont
\newcommand{\cmark}{\ding{51}}%
\newcommand{\xmark}{\ding{55}}%

% Numbered captions of tables, pictures, etc.
\setbeamertemplate{caption}[numbered]

\theoremstyle{remark}
\newtheorem*{remark}{Remark}
\theoremstyle{definition}

\usetheme{Stanford} 
\input{./style_files_unipd/my_beamer_defs.sty}
\logo{\includegraphics[height=0.53in]{./style_files_unipd/unipd_logo_bg.png}}

% commands to relax beamer and subfig conflicts
% see here: https://tex.stackexchange.com/questions/426088/texlive-pretest-2018-beamer-and-subfig-collide
\makeatletter
\let\@@magyar@captionfix\relax
\makeatother

\title[Sample title]{Sample title}

\begin{document}

\author[Thomas Jhonson]{
    \begin{tabular}{c} 
    \Large
    Thomas Jhonson\\
    \footnotesize \href{mailto:thomas.jhonson@gmail.com}{thomas.jhonson@gmail.com}
\end{tabular}
\vspace{-4ex}}

\institute{
    \vskip 5pt
    \begin{figure}
        \centering
        \begin{subfigure}[t]{0.5\textwidth}
            \centering
            \includegraphics[width=1.00in]{./style_files_unipd/unipd_logo_con_testo.png}
        \end{subfigure}%
        ~ 
        \begin{subfigure}[t]{0.5\textwidth}
            \centering
            \includegraphics[width=1.00in]{./style_files_unipd/logoDM.png}
        \end{subfigure}
    \end{figure}
    \vskip 5pt
    Dipartimento di Matematica “Tullio Levi-Civita”\\
    Università degli Studi di Padova\\
    \vskip 3pt
}

\date{July 23, 2020}
% \date{\today}

\begin{noheadline}
\begin{frame}\maketitle\end{frame}
\end{noheadline}

\setbeamertemplate{itemize items}[default]
\setbeamertemplate{itemize subitem}[circle]

\begin{frame}
    \frametitle{Overview} % Table of contents slide, comment this block out to remove it
    \tableofcontents % Throughout your presentation, if you choose to use \section{} and \subsection{} commands, these will automatically be printed on this slide as an overview of your presentation
\end{frame}

\section{Example}
\begin{frame}{Example}
hello!  % ok
àèòù    % ok
ì       % ERROR!
\end{frame}
\end{document}

EDIT: You can reproduce the error just writing the letter "ì" using this template: https://www.overleaf.com/latex/templates/armlab-latex-beamer-template/hndzfqkwrbyb

The error message says that I used "item" out of a list environment, that I used \spacefactor in internal vertical mode and that I missed a $, all this for an "ì".

  • 3
    On my system, the "Stanford" theme doesn't exists and obviously your two custom files neither, but without them the code works fine (except for a missing \end{document}. So the error seems to be in the code you didn't share. – Marcel Krüger Jul 11 at 18:08
  • 1
    How or where is the color orangeEX defined? – Mico Jul 11 at 18:11
  • 5
    The code you posted doesn't contain an attempt to typeset àèìòù. It's therefore not usable as a diagnostic tool. Please edit your posting so that the code actually generates the problem behavior you wish to fix. – Mico Jul 11 at 18:15
  • 1
    The bug requiring \let\@@magyar@captionfix\relax has long been fixed. – egreg Jul 11 at 21:55
  • 1
    For posting a MWE to TeX.SE, you should remove all unnecessary packages. Do you still get the error if you don't use Beamer? Do you still get the error if you have only \documentclass{article} \usepackage[utf8]{inputenc} \begin{document} àèìòù \end{document}? – Teepeemm Jul 12 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.