1

I have a problem with typesetting Libertine's ligatures using pdfLaTex, which, by some experimentation, I have localised to the following three lines of code:

\usepackage[utf8]{inputenc}
\usepackage[T1, T2A]{fontenc}
\usepackage{libertine}

The T2A encoding is used, because I need a way to display Cyrillic characters.

The problem itself is, the ligatures do not work: pdfLaTex renders them like incorrect ligatures with pdfLaTex

while LuaLaTex and XeLaTex both produce correct ligatures with LuaLaTex and XeLaTex

Libertine's CTAN documentation does say about features unavailable to pdfLaTeX, but common English ligatures are not one of them. Moreover, everything seems to work everywhere when I do not require T2A as an encoding. What can be the cause of this?

4
  • Welcome to TeX.SE. Are you sure you need to set T2A option under pdfLaTeX just to display cyrillic characters? It would seem that this option causes the ff, fi, fl, ffi, and ffl ligature not to get active under pdfLaTeX.
    – Mico
    Jul 12, 2020 at 12:06
  • @Mico There’s no absolutely strong requirement for pdfLaTeX, but it is preferred for being much gentler with my computing resources and compiling more than twice as fast. I suppose I do not yet need advanced scripting features that come with other options. Besides, It would just be interesting to understand why some things work and others don’t.
    – Mike Land
    Jul 12, 2020 at 12:15
  • you should use T1 encoding when you write latin, switch to T2A only for the cyrillic parts. Jul 12, 2020 at 12:17
  • @MikeLand My recommendation is to use LuaTeX when you can and PDFTeX when you have to. The old 8-bit fonts from last century work less well, are more complicated, and aren’t compatible with anything else. One nice feature you’ll get with babel on LuaTeX: you can type in Cyrillic and it will just work, including changing the language for you and hyphenating correctly.
    – Davislor
    Jul 17, 2020 at 0:58

1 Answer 1

1

\usepackage[T2A,T1]{fontenc} will make T1 encoding the default. Then use

{\fontencoding{T2A}\selectfont ... } for cyrillic text.

3
  • Even better, load babel and get hyphenation.
    – Davislor
    Jul 17, 2020 at 0:35
  • I just tried this because I needed some cyrillic text but it created (of all things) type 3 MetaFont glyphs for CMR… This is TeXLive 2016.
    – dumetrulo
    Oct 19, 2020 at 13:05
  • So update your TeXLive .
    – user22108
    Oct 19, 2020 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.