1

I am using Roman page numbering for my bibliography. It therefore starts at page IV.

Somehow, it appears as VI in the table of contents (which actually is the last page of the bibliography).

Is there a possibility to change this to IV?

\newpage
\pagenumbering{Roman}
\setcounter{page}{4}
\printbibliography[title=Literaturverzeichnis]
\renewcommand\bibname{Literaturverzeichnis}
\addcontentsline{toc}{section}{Literaturverzeichnis}
  • Please provide a minimal working example (MWE) reproducing your problem. – epR8GaYuh Jul 12 at 12:42
1

Assuming you use biblatex you can use the heading=bibintoc option for printbibliography to include the bibliography in the table of contents. By using this option, you do not need to redefine the bibname and also the addcontentsline command is not required.

Here is working minimal example:

\documentclass{scrartcl}

\usepackage{biblatex}
\addbibresource{biblatex-examples.bib}

\begin{document}

\tableofcontents
\nocite{*}

\newpage
\pagenumbering{Roman}
\setcounter{page}{4}
\printbibliography[title=Literaturverzeichnis, heading=bibintoc]
%\renewcommand\bibname{Literaturverzeichnis}
%\addcontentsline{toc}{section}{Literaturverzeichnis}

\end{document}

Edit: The reason for the incorrect page number is that

  • first printbibliography outputs the heading (on page IV) as well as the content for the bibliography (filling page IV to VI) and
  • then the addcontentsline creates the entry for the table of contents (at this point the page number is VI)

You would have to insert the addcontentsline directly after the heading of the bibliography and before the content of the bibliography is printed. The option heading=bibintoc does that for you.

| improve this answer | |
  • Thank you very much! That was super quick and easy to insert! Worked out fine! – Katharina Klein Jul 12 at 13:09
  • I tried your MWE and all that I got was an empty "Contents" list with warnings about Empty bibliography on... and Please (re)run Biber on ... (which I did do). – Peter Wilson Jul 13 at 17:07
  • @PeterWilson If you don't have a file bibliography.bib with some references, then the code as posted probably will not compile to a document with bibliography. Replace \addbibresource{bibliography.bib} with \addbibresource{biblatex-examples.bib} to load a .bib file that is available on all systems with biblatex and run LaTeX, Biber, LaTeX, LaTeX. – moewe Jul 13 at 19:19
  • @moewe Thanks for that input, I included your improvement in the answer. :) – flammermann Jul 14 at 20:30
-1

All you needed to do was to put the \addcontenstline{... before the bibliography. Putting it after the bibliography picks up the last page of the bibliography.

For example:

% bibintocprob.tex SE 553203
\documentclass{article}
\usepackage{lipsum}
\begin{document}
\tableofcontents
\section{First}
\lipsum[1]
\newpage
\pagenumbering{Roman}
\setcounter{page}{4}
\addcontentsline{toc}{section}{References}
\begin{thebibliography}{Dillo 83}
\bibitem[Knud 66]{kn:gnus} D. E. Knudson. \textit{1966 World Gnus Almanac.}
\end{thebibliography}
\end{document}

As you hadn't provided an MWE I had to make one up and used the LaTeX "Doing It Yourself" bibliography code style.

| improve this answer | |
  • 1
    This example is only applicable if you are using the basic LaTeX bibliography mechanism or bibtex with a standard LaTeX class. If one is using the hyperref package it is recommended to insert a phantomsection before the addcontentsline to allow the hyperlink to point to the correct page even if there is no newpage before the bibliography. If biber is used, the accepted answer provides a cleaner solution. If the KOMA classes are used, the cleaner solution would be to use bibliography=totoc in the class options. – flammermann Jul 12 at 21:27
  • @flammermann Replace 'biber' with 'biblatex' (Biber is just the 'backend' that reads the .bib file and produces a LaTeX-readable data format; the actual typesetting is done by biblatex), but other than that I completely agree. – moewe Jul 13 at 6:30
  • @flammermann Please see my comment about your solution. Mine at least worked even if it didn't fit your idea of what the OP was doing.` (Why didn't your "solution" have anything to say about the hyperref package which it seems that you consider I should have commented on?) --- GOM – Peter Wilson Jul 13 at 17:12
  • @moewe Again you are correct, thanks for that! :) – flammermann Jul 14 at 20:35
  • 1
    @PeterWilson The OP's code is using \printbibliography clearly indicating that biblatex is the bibliography package of interest. – flammermann Jul 18 at 0:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.