0

I'm using Elsevier single column using Overleaf. When I include images using the following code, I saw an extra comma added on the top of the image. My file is around 40 pages and I have many figures with this comma. The output of the code is shown below: enter image description here Thanks in advance for your help.

\documentclass[a4paper,fleqn]{cas-sc}
\usepackage{cite}
\usepackage{float}
\usepackage{amsmath,amssymb,amsfonts}
\usepackage{algorithmic}
\usepackage[utf8]{inputenc}
\usepackage{graphicx}
\usepackage{textcomp}
\usepackage{xcolor}
\usepackage{dsfont}
\usepackage{amsmath}
\usepackage{tabularx,booktabs}
\usepackage{multicol}
\usepackage{longtable}
\usepackage[flushleft]{threeparttablex}
\usepackage{supertabular}
\usepackage{deluxetable}
\usepackage{nicefrac}
\usepackage{longtable,pdflscape,booktabs}
\usepackage{array}
\newcolumntype{P}[1]{>{\centering\arraybackslash}p{#1}}
\usepackage[justification=centering]{caption}
\usepackage[center]{caption}
\usepackage{amsmath}
\usepackage[pdftex]{graphicx}
\usepackage{bm}
\usepackage{cite}
\usepackage{amsmath,amssymb,amsfonts}
\usepackage{algorithmic}
\usepackage[utf8]{inputenc}
\usepackage{graphicx}
\usepackage{textcomp}
\usepackage{xcolor}
\usepackage{dsfont}
\usepackage{amsmath}
\usepackage{tabularx,booktabs}
\usepackage{multicol}
\usepackage{longtable}
\usepackage[flushleft]{threeparttablex}
\usepackage{supertabular}
\usepackage{longtable,pdflscape,booktabs}
\usepackage{array}
\usepackage{xtab,afterpage}
\def\BibTeX{{\rm B\kern-.05em{\sc i\kern-.025em b}\kern-.08em
    T\kern-.1667em\lower.7ex\hbox{E}\kern-.125emX}}
\usepackage[authoryear,longnamesfirst]{natbib}
\usepackage[justification=centering]{caption}
\usepackage[center]{caption}
\def\tsc#1{\csdef{#1}{\textsc{\lowercase{#1}}\xspace}}
\tsc{WGM}
\tsc{QE}
\tsc{EP}
\tsc{PMS}
\tsc{BEC}
\tsc{DE}
\makeatletter
\patchcmd{\@maketitle}{\raggedright}{\centering}{}{}
\patchcmd{\@maketitle}{\raggedright}{\centering}{}{}
\makeatother
\begin{document}
\let\WriteBookmarks\relax
\def\floatpagepagefraction{1}
\def\textpagefraction{.001}

\section{Introduction}
Even though the vehicle is driven by a human driver, this is still a major challenge.
\begin{center}
\begin{figure}[h]
\includegraphics[width=\linewidth]{15.PNG}
\caption{Summary of Levels of Driving Automation}
 \label{fig:SAE1}
\end{figure} 
\end{center}

By increasing the level of automation.

\end{document}
  • Please prepare a complete minimal working example (MWE) that allows others to reproduce the issue you get. Apart from that, the screenshot of the output was not produced with the code fragment you included in your question. Please clarify that. – leandriis Jul 25 at 9:47
  • Thanks, @leandriis for your reply. I updated it. I hope it is clear now. Thanks for your help. – Hesham Jul 25 at 22:39
  • 2
    Welcome to TeX.SX! Your document has a lot of errors, from packages that don't exist, to packages that shouldn't be loaded, and package option clashes. However even if I ignore those errors, I don't see a comma as you show. Please make sure your example shows the problem. – Phelype Oleinik Jul 26 at 2:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.