1

I'm having a dashed line issue using natbib and having replaced with a dashed line. This is similar to previously posted issues (see 1, 2, 3, 4) but none of these are in aer style specifically. How can I stop dashed lines from showing up in my references? dashed=false does not work for me.

\documentclass[12pt]{article}
\usepackage{times}

\usepackage[]{natbib}
\usepackage{booktabs,caption,fixltx2e}
\usepackage[margin=1in]{geometry}
\usepackage{filecontents}
\begin{filecontents}{mini.bib}
@unpublished{bgs2015mac,
  title={Memory, Attention and Choice},
  author={Bordalo, Pedro and Gennaioli, Nicola and Shleifer, Andrei},
  note={Mimeo, Harvard University},
  year={2017}
}

@unpublished{bgs2019mac,
  title={Memory, Attention and Choice},
  author={Bordalo, Pedro and Gennaioli, Nicola and Shleifer, Andrei},
  note={Mimeo, Harvard University},
  year={2020}
}

\end{filecontents}


\raggedbottom
%\input{tcilatex}
\begin{document}

\title{\textbf{My Paper Title} \\
\bigskip }

\maketitle


\nocite{*} 

\bibliographystyle{aer}
\bibliography{mini}

\end{document}

produces: enter image description here

  • 4
    The aer bib style is programmed to replace repeated author names with em-dashes. If you do like this setting, you should probably not be using the aer bib style to begin with. – Mico Jul 27 at 4:24
  • I agree, it just that this is my PI's preferred style so I can't really change it – John-Henry Jul 27 at 15:04
  • 1
    In that case, just inform your PI that the aer bibliography style is programmed to substitute repeated authors' names with em-dashes and that loading the natbib citation management system cannot affect this programming decision. Leave it up to him/her to decide whether it's necessary to switch to a different bibliography style. (If he/she does decide on such a switch, you could recommend the plainnat bibliography style...) – Mico Jul 27 at 15:59
  • Good advice, thanks @Mico! – John-Henry Jul 27 at 16:24
  • 1
    Life is a series of compromises, isn't it? If you really need the authors' names to be boldfaced, please post a new query and ask how this may be achieved while using natbib and, say, the plainnat bibliography style. – Mico Jul 27 at 16:58
0

This can be solved by using the closely related AER argument of the AEA document class

\documentclass[AER]{AEA} %%% change here
\usepackage{times}

...

\bibliographystyle{aea}  %% change here
\bibliography{mini}

\end{document}

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.