The similar post I have found were no solution to my problem.
I want to add the DOI of an paper or book (ISBN or DOI) in the references using the style "angew" (Angewandte Chemie International Edition).
The .bst file looks like it has the option to activate DOI but I could not figure out how to do that.
I will post a minimal example with my packages, a bib file and the .bst. I hope you can help me.

        \usepackage[colorlinks, linkcolor = black, citecolor = black, filecolor = black, urlcolor = blue]{hyperref}
        \usepackage[capitalise, nameinlink, noabbrev]{cleveref} %after hyperref!
\blindtext \cite{Fridman.2012,Baylet.2012}

Bib file

 abstract = {{\textquotedbl}Applied Catalysis B, Environmental{\textquotedbl}, 113-114 (2011) 31-36. 10.1016/j.apcatb.2011.10.026},
 author = {Baylet, A. and Mar{\'e}cot, P. and Duprez, D. and Jeandel, X. and Lombaert, K. and Tatibou{\"e}t, J. M.},
 year = {2012},
 title = {Synergetic effect of plasma/catalysis hybrid system for CH4 removal},
 keywords = {Carbon monoxide;Methane;Monolith;Non-thermal plasma discharge;Palladium},
 pages = {31--36},
 volume = {113-114},
 issn = {09263373},
 journal = {Applied Catalysis B: Environmental},
 doi = {10.1016/j.apcatb.2011.10.026},
 file = {c5d87ebd-cb76-4e5d-b9e5-2cc7650b6989:C\:\\Users\\oekofresh\\AppData\\Local\\Swiss Academic Software\\Citavi 6\\ProjectCache\\lmpdduos0lw542joqndds2oeu80yn1t2ka3wcazgqlvf2p3bwjy\\Citavi Attachments\\c5d87ebd-cb76-4e5d-b9e5-2cc7650b6989.pdf:pdf}

 abstract = {},
 author = {Fridman, Alexander A.},
 year = {2012},
 title = {Plasma chemistry},
 address = {Cambridge},
 publisher = {{Cambridge University Press}},
 isbn = {9780521847353},
 doi = {10.1017/CBO9780511546075},

.bst "angew" This is the .bst file 1drv.ms/u/s!AvQ5xKNcyy9jhO1P0pEXB7GXe2-3VQ?e=uYdgL9


The easiest way is to use the rsc package to set up the controls: the option you need is usedoi.

\usepackage[usedoi]{rsc} % Loads natbib

It can be done manually, but that is much less a 'user' function.

  • I've minimised the example: the other packages are not crucial.
    – Joseph Wright
    Jul 28 '20 at 10:51
  • That worked!! Thanks a lot!!
    – Niklas
    Jul 28 '20 at 11:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.