1

When using style=publist from biblatex, book entries are printed following this model.

2020b. Book Title. Location: Publisher.

I would like to remove the letters that come with the years (i.e. the extrayear) and have that same entry printed as follows:

2020. Book Title. Location: Publisher.

I want all entry types to have its extrayear removed and that only its date is printed. I said date and not year because I don't want to prevent some entries from being printed as follows:

Dec. 6, 2019. "Article title". In: Journal (51), pp. 31–6.

1
  • 1
    Please consider adding an example document that reproduces the problem. Your question is of course understandable without it, but it is much easier to get started investigating this if we don't have to build your setup from scratch. – moewe Jul 31 '20 at 4:55
2

Either use the option labeldateparts=false or define

\DeclareFieldFormat{extradate}{}
2
  • +1 for labeldateparts=false. But I consider empty field formats to suppress the output very bad style, so I'd like to discourage the second option in the strongest possible terms. – moewe Jul 31 '20 at 16:02
  • OK, I retract that ;-) – JSpitzm Jul 31 '20 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.