2

The mathalpha packages provides several fonts for math typesetting, for example script and fraktur fonts. However, I tried using them and it does not work. I can only use the euler fraktur font for example:

\usepackage[frak = euler]{mathalpha}
% ...
\mathfrak{F}

works, but frak = mma for the mathematica font does not. The error message in TeXstudio reads

Font U/mmamfrak/m/n/10.95=mmamfrak at 10.95pt not loadable: Metric (TFM) file not found. \end{align}

and the TeXstudio log reads

Sorry, but miktex-makemf did not succeed. The log file hopefully contains the information to get MiKTeX going again: C:\Users\...\miktex-makemf.log Couldn't open `mmamfr.cfg' hbf2gf (CJK ver. 4.8.4)

and the logfile repeatedly reads

2020-08-01 10:42:13,976+0200 FATAL miktex-makemf - The mmamfrak source file could not be found.
2020-08-01 10:42:13,977+0200 FATAL miktex-makemf - The mmamfrak source file could not be found.
2020-08-01 10:42:13,977+0200 FATAL miktex-makemf - Info:
2020-08-01 10:42:13,977+0200 FATAL miktex-makemf - Source:
2020-08-01 10:42:13,977+0200 FATAL miktex-makemf - Line: 0

I don't have mathematica installed not any of the other fonts explicitly. Could this be the problem? How do I install these fonts if they are missing? (And if they are easily available)

I am using MikTeX version 2.9 and try to compile using PdfLaTeX

1
  • 1
    I also ran into this issue...has there been a solution found? I run in Overleaf, and using {mathalpha} on [scr=boondoxo] and [cal=euler] both work, but not the [frak=mma] or [frak=lucida]. Using [frak=euler] worked somewhat, i.e. the first few times I called \mathfrak it was ok but then the next few times it got "Too many math alphabets in version normal" error...which went away when I deleted [frak=euler] from the {mathalpha} package line. Even more mysteriously even after I deleted [frak=euler], \mathfrak was in euler font! Again, all other \cal and \scr fonts work perfectly fine.
    – D.R
    Oct 21, 2021 at 3:42

1 Answer 1

2

In the documentation of MATHALPHA, AKA MATHALFA PACKAGE on this link https://ctan.mirror.garr.it/mirrors/CTAN/macros/latex/contrib/mathalpha/doc/mathalpha-doc.pdf I add some important screenshots:

enter image description here

enter image description here

enter image description here

An important link of TeX.SE:

How to use fonts (the ones listed in mathalfa documentation) in math mode

You can see that in this link

http://mirror.neu.edu.cn/CTAN/macros/latex/contrib/mathalfa/mathalfa.tex

there is the file.tex of the package. Using Papeeria, to compile, I have tried a piece of code and I have not frak=mma fonts. You can compare with the documentation at page 7.

enter image description here

At this link https://ctan.org/pkg/mathematica you can download the Mathematica3.0 fonts and in this link How use Mathematica fonts with LaTeX - which method? there are the instructions.

ADDENDUM:

In this link you can find also the wolfram.map; exactly they are named wrifnt1_0_3 in the link.

enter image description here

12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .